Project

General

Profile

Task #2284

Hwloc test unstable on Jetson TK1

Added by Aleksei Iupinov over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
core library
Target version:
Difficulty:
uncategorized
Close

Description

That's the second time I see this pop up (first was month(s) ago). Does not seem to be predictable.

http://jenkins.gromacs.org/job/Matrix_PostSubmit_master/274/OPTIONS=gcc-4.8%20simd=ARM_NEON%20release-with-assert%20host=bs_jetson_tk1,label=bs_jetson_tk1/testReport/junit/(root)/HardwareTopologyTest/HwlocExecute/

[----------] 4 tests from HardwareTopologyTest
08:48:13 [ RUN      ] HardwareTopologyTest.Execute
08:48:13 [       OK ] HardwareTopologyTest.Execute (21 ms)
08:48:13 [ RUN      ] HardwareTopologyTest.HwlocExecute
08:48:13 /home/jenkins/workspace/Matrix_PostSubmit_master/2ef28f92/gromacs/src/gromacs/hardware/tests/hardwaretopology.cpp:86: Failure
08:48:13 Expected: (hwTop.supportLevel()) >= (gmx::HardwareTopology::SupportLevel::Basic), actual: 4-byte object <01-00 00-00> vs 4-byte object <02-00 00-00>
08:48:13 Cannot determine basic hardware topology from hwloc. GROMACS will still
08:48:13 
08:48:13 work, but it might affect your performance for large nodes.
08:48:13 Please mail gmx-developers@gromacs.org so we can try to fix it.
08:48:13 [  FAILED  ] HardwareTopologyTest.HwlocExecute (21 ms)

It means that the supportLevel() is SupportLevel::LogicalProcessorCount.

Associated revisions

Revision b312d389 (diff)
Added by Mark Abraham 6 months ago

Stop using hwloc on old ARM slave

We're not sure what the problem is, but it will never be
a priority to fix it.

Fixes #2284

Change-Id: I20d7662004baeba36c4b89294457da4c36128c50

History

#1 Updated by Szilárd Páll over 1 year ago

I think we should disable it, it really isn't relevant on this old 32-bit ARM chip. Alternatively, we could install a newer hwloc, but I'm not sure it's worth the effort.

#2 Updated by Erik Lindahl over 1 year ago

  • Tracker changed from Bug to Task
  • Priority changed from Normal to Low
  • Affected version deleted (git master)

This seems to be a bug in hwloc rather than Gromacs, so changing it to a task.

#3 Updated by Mark Abraham 6 months ago

  • Target version set to 2019

Still happening:

/home/jenkins/workspace/Matrix_PostSubmit_2019/964f6525/gromacs/src/gromacs/hardware/tests/hardwaretopology.cpp:86
Expected: (hwTop.supportLevel()) >= (gmx::HardwareTopology::SupportLevel::Basic), actual: 4-byte object <01-00 00-00> vs 4-byte object <02-00 00-00>
Cannot determine basic hardware topology from hwloc. GROMACS will still

work, but it might affect your performance for large nodes.
Please mail gmx-developers@gromacs.org so we can try to fix it.

We can just disable hwloc in the matrix

#4 Updated by Gerrit Code Review Bot 6 months ago

Gerrit received a related patchset '1' for Issue #2284.
Uploader: Mark Abraham ()
Change-Id: gromacs~release-2018~I20d7662004baeba36c4b89294457da4c36128c50
Gerrit URL: https://gerrit.gromacs.org/8634

#5 Updated by Mark Abraham 6 months ago

  • Target version changed from 2019 to 2018.4

#6 Updated by Mark Abraham 6 months ago

  • Status changed from New to Resolved

#7 Updated by Paul Bauer 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF