Project

General

Profile

Bug #2317

Incorrect warning about PME ranks during cpt restart

Added by Erik Lindahl almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

When restarting from a checkpoint and using the same setup with separate PME ranks as for the checkpoint, gromacs incorrectly warns about PME rank mismatching, and thinks the current run does not use separate PME ranks.

History

#1 Updated by Paul Bauer almost 2 years ago

Hello, I have been trying to reproduce this using a small test system and the beta release version, but no luck. Could you send me the way you set up the simulation?
Thanks!

#2 Updated by Erik Lindahl almost 2 years ago

It might have been fixed by Mark's other patch for selecting PME nodes automatically. Will test tonight.

#3 Updated by Berk Hess almost 2 years ago

I think I noticed this issue as well around the time this got filed. But now I can not reproduce it with the code from around that time and neither with current HEAD of release-2018.

#4 Updated by Mark Abraham almost 2 years ago

I assume this is fixed, but haven't tried

#5 Updated by Erik Lindahl almost 2 years ago

  • Status changed from New to Resolved

Fixed by Mark's change to fix the separate PME node assignment.

#6 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF