Project

General

Profile

Bug #237

grompp fails to compile

Added by Claus empty about 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have a cluster system of xeon cpu's based on the rocks version 5.0 distribution, and I have installed gromacs version 4.0 from the source code.

Trying to compile with:

grompp -f file.mdp -c file.gro -p file.top

I get the following error :

Program grompp, VERSION 4.0
Source code file: topio.c, line: 415

Fatal error:
Syntax error - File file.top, line 4
Last line read:
' [ system ]'
Invalid order for directive system

The problem is that I'm not facing such a problem with versions 3.3.2 and 3.3.3.

gromacs4bug_files.zip (39.2 KB) gromacs4bug_files.zip all the imput files Claus empty, 10/26/2008 10:42 AM

History

#1 Updated by Erik Lindahl about 12 years ago

Please upload example files to reproduce the bug.

#2 Updated by Claus empty almost 12 years ago

Created an attachment (id=308)
all the imput files

These are the input files I'm using that reproduce the bug.
The command I use is :
grompp -f giol_pp.mdp -c giol.gro -p giol.top

#3 Updated by Berk Hess almost 12 years ago

Your top file is incorrect.
You use: # include
the space is not allowed, it should be
#include

Apparently your C pre processor (which is used by gmx 3.3)
does not complain about this.
Gromacs 4.0 uses it's own C pre processor, which can not
process this (incorrect) format.

Berk

#4 Updated by Claus empty almost 12 years ago

(In reply to comment #3)

Your top file is incorrect.
You use:
  1. include
    the space is not allowed, it should be
    #include

Apparently your C pre processor (which is used by gmx 3.3)
does not complain about this.
Gromacs 4.0 uses it's own C pre processor, which can not
process this (incorrect) format.

Berk

Hello,

thank you very much! Now I have to do minor changes to my files. It is working.
I also have to add that while experimenting, I made one whole topology file and I didn't face any problem.

Yours Sincerely,
Nikos

Also available in: Atom PDF