Project

General

Profile

Bug #2377

Useless spam of "No option -multi"

Added by Aleksei Iupinov 13 days ago. Updated 7 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

Gerrit change I96e19acb0e15d3f42b0929f555b451299a2882e4 (which was merged into release-2018 pretty much last minute) made it so that every rank of the simulation prints "No option -multi" into stderr when "-multi" is not set.
The function opt2bSet does not just "return TRUE when this option has been found on the cmd-line", per documentation, but issues that print when the option is NOT found.

This is not very nice, and also shows that we should probably have an output tests for at least minimal subset of the common mdrun use cases.


Related issues

Related to GROMACS - Bug #2136: mdrun -noconfout checkpointing issueClosed

Associated revisions

Revision 35654e9a (diff)
Added by Berk Hess 8 days ago

Avoid mdrun echoing "No option -multi"

mdrun would print as many messages "No option -multi" as there
are MPI ranks to stderr.
Also updated -multi to -multidir in an error message.

Fixes #2377

Change-Id: I697956e28f904b148974183ad85ed7ed4ec82221

Revision 04f3da89 (diff)
Added by Berk Hess 7 days ago

Replace stderr prints in filenm.cpp by asserts

Refs #2377

Change-Id: Iec556bf03b613e27c6b98e09577801f4d0701d06

History

#1 Updated by Aleksei Iupinov 13 days ago

  • Related to Bug #2136: mdrun -noconfout checkpointing issue added

#2 Updated by Berk Hess 13 days ago

The cause is that the deprecated features change added a check for -multi in the file options, not the normal options list.

#3 Updated by Szilárd Páll 13 days ago

  • Target version set to 2018.1

#4 Updated by Gerrit Code Review Bot 12 days ago

Gerrit received a related patchset '1' for Issue #2377.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2018~I697956e28f904b148974183ad85ed7ed4ec82221
Gerrit URL: https://gerrit.gromacs.org/7465

#5 Updated by Berk Hess 12 days ago

  • Status changed from New to Fix uploaded

#6 Updated by Mark Abraham 9 days ago

Aleksei Iupinov wrote:

The function opt2bSet does not just "return TRUE when this option has been found on the cmd-line", per documentation, but issues that print when the option is NOT found.

Joyyy. We should make a redmine task to overhaul that.

This is not very nice, and also shows that we should probably have an output tests for at least minimal subset of the common mdrun use cases.

Once we have all our output using the MDLogger functionality, now it makes sense to set up the ability to prepare an mdrun, and observe that we get the messages we expect, and not others, and perhaps that some messages have ordering association. But right now, all we can do is diff a log file (or worse, parse it and then diff the parsed version) and that diff will now be friction against change (as the warnings check in regressiontests is now).

None of that will help finding this, because some random component spamming stderr isn't readily detectable.

#7 Updated by Aleksei Iupinov 9 days ago

As I was explained later, that print would be better off as an assert.
That function is not looking for argument values, it's looping over arguments supported by the binary itself.
I was also not aware that tMPI binary does not recognize "-multi".
More over, that function is actually looking for the filename options only :-)

#8 Updated by Berk Hess 8 days ago

  • Status changed from Fix uploaded to Resolved

#9 Updated by Gerrit Code Review Bot 7 days ago

Gerrit received a related patchset '1' for Issue #2377.
Uploader: Berk Hess ()
Change-Id: gromacs~master~Iec556bf03b613e27c6b98e09577801f4d0701d06
Gerrit URL: https://gerrit.gromacs.org/7485

Also available in: Atom PDF