Project

General

Profile

Bug #2416

Task #2391: re-enable TPI test

TPI producing invalid results with nsteps too small

Added by Aleksei Iupinov over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Running TPI on a sample system (spc216 with methane) will quietly produce infs/nans if -nsteps argument is set to anything but default value.

gmx mdrun -rerun spc216.gro

or

gmx mdrun -rerun spc216.gro -nsteps -2

Reading frame       0 time    0.000   mu  1.368e+01 <mu>  1.368e+01

gmx mdrun -rerun spc216.gro -nsteps 20
(value is the same as in the initial mdp)

Reading frame       0 time    0.000   mu        inf <mu>        inf

(This is likely not the last of it since I'm also getting infs without nsteps but with some other arguments specified)

Associated revisions

Revision 40d8c458 (diff)
Added by Aleksei Iupinov over 1 year ago

Advice users on infinite output of TPI

Fixes #2416

Change-Id: I6202154bc2a24377d036e5c115f2c90b1c678dda

History

#1 Updated by Aleksei Iupinov over 1 year ago

Alright, so Berk has explained to me how this is a feature and not a bug - not getting enough samples with low number of nsteps.
I would still think the output could be a bit more user-friendly.
By the way, nsteps 0 is the special case that prints nan.

#2 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2416.
Uploader: Aleksei Iupinov ()
Change-Id: gromacs~master~I6202154bc2a24377d036e5c115f2c90b1c678dda
Gerrit URL: https://gerrit.gromacs.org/7597

#3 Updated by Berk Hess over 1 year ago

  • Status changed from New to Fix uploaded
  • Priority changed from Normal to Low
  • Target version changed from 2016.6 to 2019

#4 Updated by Berk Hess over 1 year ago

  • Subject changed from TPI producing invalid results with nsteps specified to TPI producing invalid results with nsteps too small

#5 Updated by Aleksei Iupinov over 1 year ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Mark Abraham over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF