Project

General

Profile

Bug #2417

Physical validation tests fail with default installation

Added by Paul Bauer over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
testing
Target version:
Affected version - extra info:
Likely happening in all versions that have the physical validation suite, but I didn't test that
Affected version:
Difficulty:
uncategorized
Close

Description

When testing the physical validation suite on my system, the 'ens_water_md_verlet_settle_pme_vr_pr' and 'ens_water_md-vv_verlet_none_pme_nh_mttk' tests fail the test for the Maxwell-Boltzmann distribution of the kinetic energies.

During analysis I saw that this is due to insufficient sampling of the base systems for those tests, as increasing the sampling length to 2ns lead to the tests passing again. This was also confirmed by manually analyzing the outputs and plots.
The question is if the sampling of those tests should be increased, so that users running the test suite are not confused/worried that they are seeing test failures.


Related issues

Related to GROMACS - Feature #2070: Physical validation testingIn Progress

History

#1 Updated by Mark Abraham over 1 year ago

#2 Updated by Mark Abraham 9 months ago

Any thoughts here, Pascal?

#3 Updated by Pascal Merz 9 months ago

  • Status changed from New to Accepted

This problem disappears when using a newer version of the physical validation package - change to be uploaded to gerrit soon.

#4 Updated by Paul Bauer 8 months ago

I tested the package again with release-2019-beta1 and everything passes the tests there in a default installation with and without GPU support.

#5 Updated by Pascal Merz 8 months ago

Yes, I can't reproduce it with release-2019 either. I would still like to move to a newer version of the package (and get rid of the licensing ambiguity we have now), but that proved to take a bit more time than I hoped, and it's beyond the scope of this bug.

#6 Updated by Paul Bauer 8 months ago

  • Status changed from Accepted to Rejected

Closed for now then. Still would be interesting where this got fixed ...

#7 Updated by Pascal Merz 8 months ago

Which version did you observe the problem with? 2018.1? Any other?

#8 Updated by Paul Bauer 8 months ago

Only in the 2018.1. Might be one of the bugs we fixed in the meantime.

#9 Updated by Paul Bauer 6 months ago

  • Status changed from Rejected to Closed

Also available in: Atom PDF