Project

General

Profile

Bug #244

mdrun memory error

Added by michal kolar almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=309)
tpr of structure, which causes mdrun crash

I downloaded gromacs 4.0 official release,
compiled with gcc 4.1.2 and icc 10.1, single and double precision.

When running mdrun I get the following error:
  • glibc detected * free(): invalid next size (normal): 0x0000000000846c20 *

The error appears only when md integrator is used (minimization works fine) and only when some coordinates are used (I have a set of 4 similar DNA structures, from which two works well). Problems are with all mdruns compiled with different compilers as well as with single and double precision.

Gromacs 3.3 works with all 4 structures well.

topol.tpr (1.08 MB) topol.tpr tpr of structure, which causes mdrun crash michal kolar, 10/29/2008 04:42 PM

History

#1 Updated by Berk Hess almost 11 years ago

Hi David,

This segv is probably caused by line 575 of splitter.c
where isid is -1.
I don't understand this merge_sid code completely.
I rev 1.18 you changed the check on line 574 from (isid >= 0)
to (nsid >= 0).
There should at least be a check for isid >= 0.
Do we also need the nsid >= 0 check?

Berk

#2 Updated by Berk Hess almost 11 years ago

I looked at the code again and nsid is always >= 0,
so I assume David accidentally changed the check.
I changed it back.
This fixes segv's when SHAKE or particle decomposition is used.

Berk

Also available in: Atom PDF