Project

General

Profile

Bug #2476

gmx trjconv segfaults when converting gro file to xtc when no tpr is given

Added by Viveca Lindahl 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
2018.2-dev-20180410-f2c9e77
Affected version:
Difficulty:
uncategorized
Close

Description

gmx_debug trjconv -f confout.gro -o traj_comp.xtc

results in a segmentation fault. In topology.cpp:180

sfree(top->idef.il[f].iatoms);

attempts to free iatoms=0x0.

valgrind.log (83.3 KB) valgrind.log valgrind output for segfault Viveca Lindahl, 04/11/2018 01:08 PM

Related issues

Is duplicate of GROMACS - Bug #2430: gmx trjconv gets invalid pointer if tpr is not providedClosed

History

#1 Updated by Viveca Lindahl 4 months ago

  • Description updated (diff)

#2 Updated by Viveca Lindahl 4 months ago

  • Is duplicate of Bug #2430: gmx trjconv gets invalid pointer if tpr is not provided added

#3 Updated by Viveca Lindahl 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF