Project

General

Profile

Bug #2493

Command line file passing no longer works for gmxana tools

Added by Joe Jordan over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The legacy gmx analysis tools no longer are able to read files passed from the command line such as trajectory or topology information. I am pretty sure this is the result of #7620 where t_filenm is changed from arrays of chars to std::arrays. As proof, I cite that this patch updated gmx_sans which is now broken, but left untouched gmx_saxs which still works. I have only tested about half of the gmx_* tools changed in patch #7620 but none of them worked so I suspect all are broken.

lysozyme-water.xtc (25.6 KB) lysozyme-water.xtc Joe Jordan, 04/27/2018 10:39 AM
lysozyme-water.tpr (202 KB) lysozyme-water.tpr Joe Jordan, 04/27/2018 10:39 AM

Associated revisions

Revision 249ed9e2 (diff)
Added by Paul Bauer over 1 year ago

Fix file reading in gmx sans

Fixes #2493

Change-Id: Ia48008e476b1cf1a6d5e32a06103d16f92f18064

History

#1 Updated by Paul Bauer over 1 year ago

so, I just tried running trjconv yesterday with master and it worked without any issues, so I'm not sure what is happening here.
Can you provide an example that is broken, together with the git version you are using?
Thanks!

#2 Updated by Joe Jordan over 1 year ago

Here are an xtc/tpr combo that I have been using for testing. It looks like I was premature last night in saying that several tools were not working, but gmx sans is indeed broken. I am wondering now why the many other tools in gmxana that use t_filenm were not also C++ified.

Command line:
gmx sans -f lysozyme-water.xtc -s lysozyme-water.tpr

-------------------------------------------------------
Program: gmx sans, version 2019-dev-20180426-53b561f
Source file: src/gromacs/commandline/cmdlineparser.cpp (line 276)
Function: void gmx::CommandLineParser::parse(int*, char**)

Error in user input:
Invalid command-line options
Unknown command-line option -f
Unknown command-line option -s

#3 Updated by Paul Bauer over 1 year ago

  • Priority changed from Low to High

Confirmed now. After discussing with Aleksei, the issue seems to be that the asize macro used to determine the number of files is not typesafe and is passed the pointer to fnm instead of the static array.

#4 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '5' for Issue #2493.
Uploader: Paul Bauer ()
Change-Id: gromacs~master~Iaa75b650a3af07c8ddf4b238d2cc3a9a5ddecaaa
Gerrit URL: https://gerrit.gromacs.org/7803

#5 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '1' for Issue #2493.
Uploader: Paul Bauer ()
Change-Id: gromacs~master~Ia48008e476b1cf1a6d5e32a06103d16f92f18064
Gerrit URL: https://gerrit.gromacs.org/7804

#6 Updated by Paul Bauer over 1 year ago

  • Status changed from New to Resolved

#7 Updated by Paul Bauer over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF