Project

General

Profile

Bug #2572

1/viscosity output is wrong in gmx-2018.2, but OK in gmx-5.1.5

Added by Sun Tiedong 7 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Affected version - extra info:
only 5.1.5 and 2018.2 are tested.
Affected version:
Difficulty:
uncategorized
Close

Description

When calculating viscosity with periodic perturbation, the output average value of 1/viscosity in 2018.2 is around zero. The NEMD is set up in NVT ensemble. Only "cos-acceleration" is set, instead of "acc-grps" and "acceleration" in .mdp file. The same tpr file works with gmx-5.1.5, i.e. gives value in reasonable range.

Both versions of gromacs are compiled on CentOS 7, with gcc-7.3.1/or gcc-4.8.5, cuda-9.2, with the following cmake command:
cmake .. -DGMX_BUILD_OWN_FFTW=ON -DGMX_GPU=on

pp_0.0005.tpr (8.78 MB) pp_0.0005.tpr NEMD tpr file created with 5.1.5. Sun Tiedong, 07/12/2018 11:10 AM
gromacs_2018.4_viscosity_ppm.patch (918 Bytes) gromacs_2018.4_viscosity_ppm.patch Patch Jiannan Liu, 12/19/2018 12:51 AM
nvt_vis.mdp (1.39 KB) nvt_vis.mdp Jiannan Liu, 12/19/2018 01:45 PM
a0.gro (911 KB) a0.gro Jiannan Liu, 12/19/2018 01:45 PM

Associated revisions

Revision b14188ac (diff)
Added by Jiannan Liu 2 months ago

Missing factor of 2 in cos-acceleration

The bug was introduced in commit 69470fc4e9fd990eb53b22c17dc7a699c583d126

Last working version is 2016.5

Affected 2018 and 2019

Fixes #2572

Change-Id: Ibad31b0d8cec7c5f4b77a73b1fbab0ff114b50b6

Revision 35051360 (diff)
Added by Jiannan Liu 2 months ago

Missing factor of 2 in cos-acceleration

The bug was introduced in commit 69470fc4e9fd990eb53b22c17dc7a699c583d126

Last working version is 2016.5

Affected 2018 and 2019

Fixes #2572

Change-Id: Ibad31b0d8cec7c5f4b77a73b1fbab0ff114b50b6

History

#1 Updated by Jiannan Liu 2 months ago

Dear Developers,

I am having exactly the same issue as Sun with 2018.4. I am calculating viscosity of water. 2016.5 gives reasonable results, but 2018.4 does not. In contrast to Sun's GPU version, I am using 2018.4 with CPU version only.

Please let me know if you need more information. Hope this can be fixed soon.

Thanks,
Jiannan Liu

#2 Updated by Jiannan Liu 2 months ago

Additional note, this bug is likely due to that the acceleration term is not added during the simulation. I run the 2018.4 edr file with 2016 gmx, but it still gives wrong results.

#3 Updated by Jiannan Liu 2 months ago

Hi,

After a quick comparison with the older version, it looks like there is a factor of 2 missing. The attached patch should fix it.

Thanks,
Jiannan Liu

#4 Updated by Gerrit Code Review Bot 2 months ago

Gerrit received a related patchset '1' for Issue #2572.
Uploader: Jiannan Liu
Change-Id: gromacs~master~Ibad31b0d8cec7c5f4b77a73b1fbab0ff114b50b6
Gerrit URL: https://gerrit.gromacs.org/8852

#5 Updated by Joe Jordan 2 months ago

Please provide the files and exact command line invocations that you used in the case where it works and where it doesn't. This is needed not just so we can ensure that the fix works, but also find out when the code was first broken.

#6 Updated by Jiannan Liu 2 months ago

Here are the files and commands to reproduce.

# to run simulation, a0.gro is a pre-equilibrated water configuration
gmx pdb2gmx -f a0.gro -ff opls -water spce
gmx grompp -f nvt_vis.mdp
gmx mdrun -pin on -ntmpi 1

# get results, expected ~1700 for 1/Viscosity when \lambda is 0.12
# In 2018, the result is near zero
gmx energy -b 1000

#7 Updated by Gerrit Code Review Bot 2 months ago

Gerrit received a related patchset '1' for Issue #2572.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2019~Ibad31b0d8cec7c5f4b77a73b1fbab0ff114b50b6
Gerrit URL: https://gerrit.gromacs.org/8856

#8 Updated by Gerrit Code Review Bot 2 months ago

Gerrit received a related patchset '1' for Issue #2572.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2018~Ibad31b0d8cec7c5f4b77a73b1fbab0ff114b50b6
Gerrit URL: https://gerrit.gromacs.org/8857

#9 Updated by Jiannan Liu 2 months ago

  • Status changed from New to Resolved

#10 Updated by Paul Bauer 2 months ago

  • Target version set to 2018.5

#11 Updated by Jiannan Liu 2 months ago

#12 Updated by Paul Bauer 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF