Project

General

Profile

Bug #2640

coul-lambda affects the pressure computation of a ligand with zero partial charge

Added by zhiyi wu about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

This is a simplified and corrected version of the issue 2600.
I'm trying to compute the decoupling free energy of vdw interactions of a ligand which has zero partial changes.
Since the ligand has zero partial, changing coul-lambda shouldn't have any effect on anything.
However, setting coul-lambda to 0 yields a pressure 2.13121e+02 bar of whereas setting coul-lambda to 1 yeilds a pressure of 1.07168e+02 bar.
The commands to reproduce the results are
gmx grompp -f coul-lambdas_0.mdp -c prod.gro -o coul-lambdas_0.tpr
gmx mdrun -deffnm coul-lambdas_0 -rerun prod.gro
gmx grompp -f coul-lambdas_1.mdp -c prod.gro -o coul-lambdas_1.tpr
gmx mdrun -deffnm coul-lambdas_1 -rerun prod.gro

If you compare the pressure in coul-lambdas_1.edr and coul-lambdas_0.edr, you will notice that the pressure are different whereas they should be the same.

pressure.tgz (6.16 MB) pressure.tgz zhiyi wu, 09/07/2018 02:54 PM

Related issues

Related to GROMACS - Bug #2849: Free energy discrepancies between GROMACS versionsClosed

Associated revisions

Revision 12f01f79 (diff)
Added by Berk Hess about 2 years ago

Fix PME forces with FE without perturbed q/LJ

PME would incorrectly scale the mesh forces with lambda when no
charges or LJ atom types were actually perturbed.

Fixes #2640

Change-Id: I193d55cf76d842f5b04d3a220411282c06b08a90

Revision a507acbc (diff)
Added by Berk Hess 10 months ago

Actually fix PME forces with FE without perturbed q/LJ

PME would incorrectly ignore the mesh forces on perturbed atoms when
no charges or LJ atom types were actually perturbed.
This is because the "fix" in commit 12f01f79 incorrectly changed the
lambda value used for the PME forces from the actual lambda value
to 1 instead of to 0 as it should have been.

Fixes #2640
Fixes #3359

Change-Id: Ib19565bf017ddbd2fddc66c52be0ff9efc7e707c

Revision 7387a098 (diff)
Added by Berk Hess 10 months ago

Actually fix PME forces with FE without perturbed q/LJ

PME would incorrectly ignore the mesh forces on perturbed atoms when
no charges or LJ atom types were actually perturbed.
This is because the "fix" in commit 12f01f79 incorrectly changed the
lambda value used for the PME forces from the actual lambda value
to 1 instead of to 0 as it should have been.

Fixes #2640
Fixes #3359

Change-Id: Ib19565bf017ddbd2fddc66c52be0ff9efc7e707c

History

#1 Updated by Berk Hess about 2 years ago

  • Category set to mdrun
  • Status changed from New to Accepted
  • Target version set to 2018.4

I reproduced this issue.
Also the force on non-perturbed, charged atoms differ significantly with coul-lambda, even though the Coulomb energies do not.

#2 Updated by Berk Hess about 2 years ago

The issue disappears when not using LJ-PME. So this looks like some incorrect interaction between the Coulomb and LJ-PNE FE code.

#3 Updated by Gerrit Code Review Bot about 2 years ago

Gerrit received a related patchset '1' for Issue #2640.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2018~I193d55cf76d842f5b04d3a220411282c06b08a90
Gerrit URL: https://gerrit.gromacs.org/8333

#4 Updated by Berk Hess about 2 years ago

  • Status changed from Accepted to Fix uploaded
  • Assignee set to Berk Hess

The Coulomb forces were, incorrectly, scaled with lambda.
This bug (only) occurs when no charges are actually perturbed. Or, analogously, for LJ-PME when no atom types are actually perturbed.

#5 Updated by Berk Hess about 2 years ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Berk Hess about 2 years ago

  • Status changed from Resolved to Closed

#7 Updated by Mark Abraham almost 2 years ago

  • Related to Bug #2849: Free energy discrepancies between GROMACS versions added

Also available in: Atom PDF