Project

General

Profile

Bug #268

energy minimization differs between CG with and without parallel

Added by edbmd empty almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

drastically different convergence between CG run in parallel with domain decomposition vs CG not run in parallel.

minimize_r1.131.2.3.c (83 KB) minimize_r1.131.2.3.c fixed? src/mdlib/minimize.c Berk Hess, 12/12/2008 04:35 PM

History

#1 Updated by Berk Hess almost 11 years ago

Could you supply a tpr file and the command line for the parallel run?

Berk

#2 Updated by Berk Hess almost 11 years ago

Created an attachment (id=331)
fixed? src/mdlib/minimize.c

#3 Updated by Berk Hess almost 11 years ago

I just realized that I fixed a bug with crashes with CG and DD
a while ago.
I don't know if the system could not crash, but converge badly
due to this bug.

Could you try the fixed file I attached before and report back?

Berk

#4 Updated by Berk Hess over 10 years ago

I assume my changes to minimize.c (committed a while ago),
fixed this bug.

Can this be confirmed, so we can close this bug?

Berk

#5 Updated by Erik Lindahl over 10 years ago

Appears to work fine now. Fix will be in 4.0.3 release shortly.

Also available in: Atom PDF