Project

General

Profile

Bug #2719

PME broken with Intel OpenCL on OSX

Added by Erik Lindahl over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

At least the first run I tried using Intel OpenCL crashed with a clFFT error.

Unless it's trivial we might have to disable all PME/LJPME support for Intel OpenCL, and note in the docs that while it's possible to compile for Intel, it's not very useful for normal simulations due to this limitation.


Related issues

Is duplicate of GROMACS - Bug #2941: OpenCL fail in osx 10.13.6Closed

Associated revisions

Revision 577b4d23 (diff)
Added by Mark Abraham over 1 year ago

Make PME OpenCL enabled only for AMD devices

Other vendor devices have known issues, but fixes
are not yet complete.

Refs #2702, #2719

Change-Id: I0d443229ffe4cee3bb4029f57502f9c7fba2574d

Revision f932b909 (diff)
Added by Szilárd Páll 9 months ago

Disable PME GPU on Apple OpenCL

Apple's OpenCL compiler seems to be unable to build a functional clFFT
which leads to a runtime error that aborts the runs rather than falling
back to PME-CPU. Hence this commit disabled PME-GPU on all Apple
platform builds.

Fixes #2941 #2719

Change-Id: I6afd19a56ced2e49d16ab598cd91527e6f73a1db

History

#1 Updated by Mark Abraham over 1 year ago

Note that LJPME is not supported for GPUs ever. Intel OpenCL is still useful for NB, and given the nature of the current devices, perhaps only useful in that run mode.

#2 Updated by Szilárd Páll over 1 year ago

My guess is that your OpenCL compiler compiles 8-wide kernels, something that we should check for as neither Roland or I had time to work on to figure out where are additional sync points needed for correctness with <16-wide kernels (See #2516).

Given that it is extremely unlikely that it will be beneficial to offload PME as well as NB instead of running PME on the CPU cores concurrently with nonbondeds on the GPU, we should:
- disable PME offload with Intel GPUs (planned just didn't get to it)
- check the compiled exec size vs the minimum requirement (~ I've code, just need to dig it up and rebase it).

#3 Updated by Szilárd Páll over 1 year ago

Correction: glanced over the fact that you got a clFFT error. That likely means that clFFT doesn't work on your hardware + compiler combo. Are you running OSX? I don't think we've tested anything other than Linux with igc (and the proprietary drivers too IIRC).

#4 Updated by Erik Lindahl over 1 year ago

Yes, this is on OS X.

As Mark says, it's not an important feature to have, but we should just make sure to disable it in that case.

#5 Updated by Gerrit Code Review Bot over 1 year ago

Gerrit received a related patchset '2' for Issue #2719.
Uploader: Mark Abraham ()
Change-Id: gromacs~release-2019~I0d443229ffe4cee3bb4029f57502f9c7fba2574d
Gerrit URL: https://gerrit.gromacs.org/8653

#6 Updated by Szilárd Páll over 1 year ago

Erik Lindahl wrote:

Yes, this is on OS X.

Does OS X still provide OpenCL support? Is it maintained (e.g. for new hardware)? I'm asking not just from the pov of PME, but also for nonbonded offload to both Intel and AMD GPUs.

#7 Updated by Erik Lindahl over 1 year ago

Apple has merely announced that it will be deprecated a year from now.

This case is old hardware, but given that it's a commercial OS running on the vendor's own hardware i think it's unlikely they would randomly start to de-support hardware ahead of the formal end-of-support :-)

#8 Updated by Szilárd Páll over 1 year ago

OK. I've no hardware to test on OS X, so we'll have to ask Mac users to test with both Intel and AMD. Can you please test on your laptop?

#9 Updated by Szilárd Páll over 1 year ago

  • Subject changed from PME broken with Intel OpenCL to PME broken with Intel OpenCL on OSX

#10 Updated by Szilárd Páll 9 months ago

  • Is duplicate of Bug #2941: OpenCL fail in osx 10.13.6 added

#11 Updated by Szilárd Páll 9 months ago

  • Status changed from New to Resolved

#12 Updated by Paul Bauer 9 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF