Project

General

Profile

Bug #2745

complex/aminoacids test fails with DD error

Added by Szilárd Páll 13 days ago. Updated 4 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
2019-beta3-dev-20181107-319b8db
Affected version:
Difficulty:
uncategorized
Close

Description

DD cell 3 0 0: Neighboring cells do not have atoms:

DD cell 2 0 1: Neighboring cells do not have atoms:

-------------------------------------------------------
Program:     gmx mdrun, version 2019-beta3-dev-20181107-319b8db
Source file: src/gromacs/domdec/domdec_specatomcomm.cpp (line 598)
MPI rank:    6 (out of 8)

Fatal error:
DD cell 3 0 0 could only obtain 8 of the 13 atoms that are connected via
constraints from the neighboring cells. This probably means your constraint
lengths are too long compared to the domain decomposition cell size. Decrease
the number of domain decomposition grid cells or lincs-order.

For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors
-------------------------------------------------------

DD cell 3 0 1: Neighboring cells do not have atoms:

-------------------------------------------------------
Program:     gmx mdrun, version 2019-beta3-dev-20181107-319b8db

Power8 build, version header:

GROMACS version:    2019-beta3-dev-20181107-319b8db
GIT SHA1 hash:      319b8db422f68a1a1e9c1636a0d60999d7fef09d
Precision:          single
Memory model:       64 bit
MPI library:        thread_mpi
OpenMP support:     enabled (GMX_OPENMP_MAX_THREADS = 64)
GPU support:        disabled
SIMD instructions:  IBM_VSX
FFT library:        fftw-3.3.8
RDTSCP usage:       disabled
TNG support:        enabled
Hwloc support:      hwloc-1.11.8
Tracing support:    disabled
C compiler:         /home/pszilard/programs/gcc/7.3/bin/gcc GNU 7.3.0
C compiler flags:   -mcpu=power8 -mpower8-vector -mpower8-fusion -mdirect-move  -mvsx    -Werror=format-overflow -Wundef -Wextra -Wno-missing-field-initializers -Wno-sign-compare -Wpointer-arith -Wall -Wno-unused -Wunused-value -Wunused-parameter  -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast  -Wno-array-bounds 
C++ compiler:       /home/pszilard/programs/gcc/7.3/bin/g++ GNU 7.3.0
C++ compiler flags: -mcpu=power8 -mpower8-vector -mpower8-fusion -mdirect-move  -mvsx    -std=c++11  -Wformat-overflow -Wundef -Wextra -Wno-missing-field-initializers -Wpointer-arith -Wmissing-declarations -Wall  -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast  -Wno-array-bounds 

Related issues

Is duplicate of GROMACS - Bug #2736: bug in domain decomposition of dims without PBCClosed

History

#1 Updated by Szilárd Páll 13 days ago

The same fails with gcc 8.2 + fftpack, double precision too.

#2 Updated by Szilárd Páll 13 days ago

  • Is duplicate of Bug #2736: bug in domain decomposition of dims without PBC added

#3 Updated by Szilárd Páll 13 days ago

I think this is a duplicate.

#4 Updated by Berk Hess 4 days ago

  • Status changed from New to Closed

Also available in: Atom PDF