Project

General

Profile

Bug #2749

Strange Fluctuations with NH+PR coupling in GROMACS 2018.3

Added by Philip Handle 12 days ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Affected version - extra info:
2018.3
Affected version:
Difficulty:
uncategorized
Close

Description

I recently bought a workstation with Intel Xeon CPUs and 3 Nvidia Tesla P100 GPUs. I inteded to perform simulations on pure water. Since I also run water simulations on a CPU-HPC cluster using GROMACS 5.1.4 I wanted to use also this version on the workstation. I could, however, not compile this version on the workstation. Therefore, I decided to use the most recent GROMACS version (2018.3). It compiled fine, but test simulations produced drastically different fluctuations than the simulations using 5.1.4 (same mdp files used).

I also tried with 2018.3 (without GPU support), where I find similarly strange results, and 2016.5, where everything worked fine. The simulations I ran were
- NPT of 1000 TIP4P/2005 molecules at 1bar, 300K
- NPT of 1000 TIP4P/2005 molecules at 1bar, 240K
- Simulated annealing (- 30K/ns) of 1000 TIP4P/2005 molecules at 1 bar, starting from 240 K
(Nose-Hoover and Parinello-Rahman thermo- and barostats used.)

Attached you find simulation data of all runs showing potential energy (U), T, P, and density. At 300 K the results are similar for all versions used (T300.png). At 240 K (T240K.png) and when cooling (COOLING.png) the data obtained from 2018.3 (with and without GPU support) differ markedly from the results obtained with 5.1.4 and 2016.5.

I also performed the 2018.3 tests (including physical validation), which produced 1 error for the GPU version in the complex regression test (see 2018-GPU.txt attached) and 1 error for the CPU only version in the physical validation test ens_water_md_verlet_settle_pme_vr_pr (see 2018-CPU.txt attached).
I however, have the feeling that these fails are not responsible for the immensely large fluctuations I find in the simulations.

In the meantime I use 2016.5 for my simulations, but I still tought I'll let you know of this strange behaviour in the 2018.3 version.

In case you need additional information from my side, do not hesitate to contact me.

Best,
Philip Handle

Department of Physical Chemistry
University of Innsbruck
Innrain 52c, A-6020 Innsbruck (Austria)
+43/512/507/58015

2018-CPU.txt (9.38 KB) 2018-CPU.txt Philip Handle, 11/08/2018 04:41 PM
2018-GPU.txt (10.7 KB) 2018-GPU.txt Philip Handle, 11/08/2018 04:41 PM
COOLING.png (22.2 KB) COOLING.png Philip Handle, 11/08/2018 04:41 PM
T240.png (29.3 KB) T240.png Philip Handle, 11/08/2018 04:41 PM
T300.png (31.1 KB) T300.png Philip Handle, 11/08/2018 04:41 PM
T300.gz.tar (150 KB) T300.gz.tar Philip Handle, 11/15/2018 03:16 PM
T240.gz.tar (149 KB) T240.gz.tar Philip Handle, 11/15/2018 03:16 PM
COOLING.gz.tar (149 KB) COOLING.gz.tar Philip Handle, 11/15/2018 03:16 PM

Related issues

Related to GROMACS - Bug #2031: Bug with Parrinelo-Rahman and nstpcouple > 1Closed
Related to GROMACS - Bug #2032: Nose-Hoover multiple time stepping issueClosed

Associated revisions

Revision 3078233a (diff)
Added by Berk Hess 4 days ago

grompp now checks tau-p>=2*tau-t with NH+PR

Added check to avoid resonances when combining Nose-Hoover and
Parrinello-Rahman coupling algorithms.

Fixes #2749

Change-Id: I061d5021ba5f9c3a68336d623c06843be9addbde

History

#1 Updated by Berk Hess 7 days ago

  • Status changed from New to Feedback wanted

This looks strange.
Could you attach all input files needed to run grompp?

#2 Updated by Philip Handle 5 days ago

I uploaded archives containing the necessary input files for the three runs performed.

#3 Updated by Berk Hess 4 days ago

  • Status changed from Feedback wanted to In Progress

The large fluctuations seem to be caused by using the same resonance time for Nose-Hoover and Parrinello-Rahman. We generally advise against this. Setting tau_p to 2 ps significantly reduces the fluctuations in gmx2018. You might need a larger distance to get acceptable fluctuations.
But I have not yet found out why there is a difference in the fluctuations between 2016 and 2018.

I suppose we should add a warning in grompp for setting tau_p equal for Nose-Hoover and Parrinello-Rahman (or four tau_p <= 1.5*tau_t) and advise to have tau_p at least twice as large as tau_t.

#4 Updated by Berk Hess 4 days ago

  • Related to Bug #2031: Bug with Parrinelo-Rahman and nstpcouple > 1 added

#5 Updated by Berk Hess 4 days ago

  • Related to Bug #2032: Nose-Hoover multiple time stepping issue added

#6 Updated by Berk Hess 4 days ago

Actually the gmx2018 behavior is technically correct, as your gmx2016 runs are affected by bugs #2031 and #2032.
Of course gmx2018 is still physically incorrect. For that the only solution is separation between tau_t and tau_p.

#7 Updated by Gerrit Code Review Bot 4 days ago

Gerrit received a related patchset '1' for Issue #2749.
Uploader: Berk Hess ()
Change-Id: gromacs~release-2018~I061d5021ba5f9c3a68336d623c06843be9addbde
Gerrit URL: https://gerrit.gromacs.org/8710

#8 Updated by Berk Hess 4 days ago

  • Status changed from In Progress to Fix uploaded
  • Assignee set to Berk Hess
  • Target version set to 2018.5

I uploaded a fix for gmx 2018.5.
I thought we already had a check for this, but apparently not.

#9 Updated by Berk Hess 4 days ago

  • Status changed from Fix uploaded to Resolved

#10 Updated by Berk Hess 4 days ago

  • Subject changed from Strange Fluctuations in GROMAS 2018.3 to Strange Fluctuations with NH+PR coupling in GROMACS 2018.3

Also available in: Atom PDF