Project

General

Profile

Bug #2775

number of ranks reporting was wrong

Added by Mark Abraham 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
many versions
Affected version:
Difficulty:
uncategorized
Close

Description

The first part of md.log reported

Log file opened on Wed Nov 21 13:55:49 2018
Host: bs-gpu01  pid: 3038  rank ID: 0  number of ranks:  1
          :-) GROMACS - gmx mdrun, 2019-beta3-dev-20181119-de71ffa (-:

the rank count was not 1, there were two thread mpi ranks launched later. I think the second line is superseded by the later output (we report the node name later, the PID is not particularly useful, and the rank stuff isn't valid until thread-MPI has launched ranks, and is anyway reported later)


Related issues

Related to GROMACS - Bug #2794: Release build fails in PDB2GMX google testsClosed

Associated revisions

Revision 367d0031 (diff)
Added by Mark Abraham 7 months ago

Clean up initial log output

The rank count was incorrect when thread-MPI has not yet spawned
threads. It could only be fixed if we would have made that choice
before we open the log file, but we want to be able to report problems
to the log file from hardware detection or tpr reading which occur
before rank choice.

Host name, rank count and rank ID are all reported later, alongside
other such information, so there is no need to duplicate and
complicate our code.

PID is now reported later alongside other similar information. The log
file output looks reasonable, aligned, etc.

Noted TODO for future clean up.

Fixes #2775

Change-Id: Ifda6c44bfe28628934f4614e20eeeef436d80707

Revision 515ea06d (diff)
Added by Mark Abraham 7 months ago

Make only mdrun report process ID

Recent change 367d003106 changed where mdrun reported the process ID,
but in so doing changed various tools to also report the process ID.
This made pdb2gmx tests non-reproducible.

Since the process ID is probably only of minor value to the user, and
probably only of value to users of mdrun, this change adds support for
allowing tools to choose to print the process ID while defaulting to
not reporting it.

Fixes #2794
Refs #2775

Change-Id: Icb6e97d4d7502f12e74cbaa2c1f1a969ba99b917

History

#1 Updated by Gerrit Code Review Bot 7 months ago

Gerrit received a related patchset '1' for Issue #2775.
Uploader: Mark Abraham ()
Change-Id: gromacs~release-2019~Ifda6c44bfe28628934f4614e20eeeef436d80707
Gerrit URL: https://gerrit.gromacs.org/8741

#2 Updated by Mark Abraham 7 months ago

  • Status changed from New to Resolved

#3 Updated by Paul Bauer 7 months ago

  • Status changed from Resolved to Closed

#4 Updated by Mark Abraham 7 months ago

  • Target version set to 2019

#5 Updated by Mark Abraham 7 months ago

  • Related to Bug #2794: Release build fails in PDB2GMX google tests added

#6 Updated by Gerrit Code Review Bot 7 months ago

Gerrit received a related patchset '1' for Issue #2775.
Uploader: Mark Abraham ()
Change-Id: gromacs~release-2019~Icb6e97d4d7502f12e74cbaa2c1f1a969ba99b917
Gerrit URL: https://gerrit.gromacs.org/8799

Also available in: Atom PDF