Project

General

Profile

Bug #2778

Some pictures appear too small in the web reference manual

Added by Carsten Kutzner 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
documentation
Target version:
Affected version - extra info:
Affected version:
Difficulty:
simple
Close

Description

In the Analysis section e.g. (analysis.rst)
Fig. 50 The window of gmx view showing a box of water
Fig. 51
Fig. 53
Fig. 54
Fig. 55 has the correct rotation but is far too small
Fig. 57
Fig. 58
Fig. 61

Associated revisions

Revision 3c9bb034 (diff)
Added by Paul Bauer 12 months ago

Fix reference manual image sizes

Fixes #2778

Change-Id: Ib48afe91a938cadb7ca6b7a89ea6cb18cf9874eb

Revision 566d5f0e (diff)
Added by Paul Bauer 12 months ago

Make Imagemagick availability more visible

Changes the message type for the gmxTestImagemagick test to be a warning
when GMX_BUILD_MANUAL is ON, to make sure users see that there may be an
issue with building the full documentation.

Also change the test script to see if the new file actually gets
created, instead of checking the return code.

Refs #2778

Change-Id: I52ca5e0143bad396d0e6cfe610dac1bb13621e5f

History

#1 Updated by Paul Bauer 12 months ago

Checking this out right now when building with I7c9bb695e1dac37b83cdc82a2c0bdb53700a1156
Fig. 50 is the right way round when visualized in Chromium
Fig. 51 the same, right way around for me
Fig. 53 same
Fig. 54 and 55 also look correct for me
Fig. 57 and 58 also look fine for me
Fig. 60 and 61 are too small (62 kind of as well)

#2 Updated by Gerrit Code Review Bot 12 months ago

Gerrit received a related patchset '1' for Issue #2778.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2019~Ib48afe91a938cadb7ca6b7a89ea6cb18cf9874eb
Gerrit URL: https://gerrit.gromacs.org/8750

#3 Updated by Paul Bauer 12 months ago

  • Subject changed from Several pictures appear rotated in the web reference manual to Some pictures appear too small in the web reference manual

#4 Updated by Carsten Kutzner 12 months ago

I found out that the problem I originally reported (wrong rotation of some figures) was not caused by GROMACS but ultimately by the fact that ImageMagick's convert was not able to produce new figures during 'make webpage-sphinx' due to missing permissions. That problem, however, did go unnoticed since there were still old (rotated) versions of these figures in my build tree.
Only after deleting these, I got a proper error message:

[ 93%] Converting Sphinx input graphics file reference-manual/analysis/plots/sgangle.pdf to png
convert: not authorized `/home/ckutzne/eclipse-workspace/git-gromacs-WRITE/docs/reference-manual/analysis/plots/sgangle.pdf' error/constitute.c/ReadImage/464.
convert: no images defined `/home/ckutzne/eclipse-workspace/git-gromacs-WRITE/build2/docs/sphinx-input/reference-manual/analysis/plots/sgangle.png'
error/convert.c/ConvertImageCommand/3149.

For security reasons, recent SUSE versions apparently do not allow the use of /usr/bin/convert on PDFs (and other formats) any more unless specified otherwise in the /etc/ImageMagick*/policy.xml file.

Solution for others who run into the same problem:

In the policy.xml file, change
<policy domain="coder" rights="write" pattern="PDF" /> to
<policy domain="coder" rights="read|write" pattern="PDF" />

#5 Updated by Paul Bauer 12 months ago

Yes, we documented this before and I though the recent change that actually tests that imagemagick works picks this up :)
Did you test it with something before I1c49d683d971a5bf0b0ce217f7e9ecd60603e6e6 got merged?

#6 Updated by Carsten Kutzner 12 months ago

Just tested this again. I am post 2019-beta3, so I1c49d683d971a5bf0b0ce217f7e9ecd60603e6e6 is in.
However, make webpage-sphinx builds quietly (apart from several warnings due to undefined labels etc) and without errors. Only the begin of the reference manual then states "The manual could not be properly build because we could not convert the images for proper display without Imagemagick."
convert is however properly picked up by CMake, just cannot actually convert anything.

#7 Updated by Paul Bauer 12 months ago

I uploaded another change to make it more clear if ImageMagick is not working if people explicitly ask to build the manual.

#8 Updated by Gerrit Code Review Bot 12 months ago

Gerrit received a related patchset '1' for Issue #2778.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2019~I52ca5e0143bad396d0e6cfe610dac1bb13621e5f
Gerrit URL: https://gerrit.gromacs.org/8755

#9 Updated by Paul Bauer 12 months ago

  • Status changed from New to Resolved

#10 Updated by Paul Bauer 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF