Project

General

Profile

Bug #2809

GROMACS 2019 RC1 build fails with GMX_BUILD_OWN_FFTW=ON

Added by Paul Bauer 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
core library
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

As reported earlier on the user mailing list, the build fails with a linker issue shown below


[100%] Linking CXX executable ../../bin/template
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_destroy(gmx_fft*)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_init_1d(gmx_fft**, int, int)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_init_1d_real(gmx_fft**, int, int)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_2d_real(gmx_fft*, gmx_fft_direction, void*,
void*)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_init_2d_real(gmx_fft**, int, int, int)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_1d(gmx_fft*, gmx_fft_direction, void*,
void*)'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_cleanup()'
/opt/apps/general/binutils/2.31/bin/ld: ../../lib/libgromacs.so.4.0.0:
undefined reference to `gmx_fft_1d_real(gmx_fft*, gmx_fft_direction, void*,
void*)'
collect2: error: ld returned 1 exit status
make[2]: *** [bin/template] Error 1
make[1]: *** [share/template/CMakeFiles/template.dir/all] Error 2
make: *** [all] Error 2

I confirmed this also on my machine with a slightly different combination of gcc and cuda, and don't think it is related to this.


Related issues

Related to GROMACS - Task #2684: make sure ARM perf libs for FFTs / BLAS worksClosed

Associated revisions

Revision 2e208aef (diff)
Added by Paul Bauer 9 months ago

Fix FFTW build

Fixed the build with GMX_BUILD_OWN_FFTW terminating with a linker issue.

Fixes #2809

Change-Id: Ie1323601da220bf28d7cb00d33b520b66d9de05f

Revision b3b27048 (diff)
Added by Paul Bauer 9 months ago

Add matrix entry to test external FFTW build

Added build option and configuration to test building GROMACS with
GMX_BUILD_ONW_FFTW to catch associated issues.

Refs #2809

Change-Id: I6c8a9fc415be5386c8b336c3f4dabdac49680130

Revision f72ba08a (diff)
Added by Mark Abraham 2 months ago

Fix pre-submit build matrix and description

Pre-submit should not fail because the ftp server is not reachable, so
moved it to nightly matrix. Also recorded the intent to test
such a build.

Also fixed that the intent to test AVX_128_FMA in mixed precision was
broken in Ib2c5e14e5d89665130ae8d6c749c3230ccfe72a9. There's no
ability to test this SIMD in pre-submit without wider changes, and their
is neither large risk nor consequence of breaking it, so nightly is OK.

Refs #2809, #2629

Change-Id: I9cd41a359ba662a8a9529540c50c9a7ef546cd29

History

#1 Updated by Paul Bauer 9 months ago

The issue got introduced in cdffd532f44b775c424b51864eab61de70a8433b, looking how to fix it

#2 Updated by Gerrit Code Review Bot 9 months ago

Gerrit received a related patchset '1' for Issue #2809.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2019~Ie1323601da220bf28d7cb00d33b520b66d9de05f
Gerrit URL: https://gerrit.gromacs.org/8828

#3 Updated by Gerrit Code Review Bot 9 months ago

Gerrit received a related DRAFT patchset '1' for Issue #2809.
Uploader: Paul Bauer ()
Change-Id: gromacs~release-2019~I6c8a9fc415be5386c8b336c3f4dabdac49680130
Gerrit URL: https://gerrit.gromacs.org/8829

#4 Updated by Mark Abraham 9 months ago

  • Related to Task #2684: make sure ARM perf libs for FFTs / BLAS works added

#5 Updated by Paul Bauer 9 months ago

  • Status changed from New to Resolved

#6 Updated by Paul Bauer 9 months ago

  • Status changed from Resolved to Closed

#7 Updated by Paul Bauer 9 months ago

  • Target version changed from 2019-rc2 to 2019

Also available in: Atom PDF