Project

General

Profile

Bug #282

genbox -nmol 10 gives segmentation fault (version 4.0.3)

Added by Justin Lemkul over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

As reported to the gmx-users list:

http://www.gromacs.org/pipermail/gmx-users/2009-January/039211.html

The command that gives a segmentation fault is:

genbox -cp complex_newbox.gro -ci lig.gro -nmol 10

Values of -nmol < 4 work without error.

Version 3.3.3 on the same machine works fine. Version 4.0.3 works correctly on an AMD64 machine, so the seg fault appears to be limited to my MacBook.

complex_newbox.gro (49.7 KB) complex_newbox.gro Protein complex .gro file Justin Lemkul, 01/27/2009 01:06 PM
lig.gro (1.46 KB) lig.gro ligand .gro file Justin Lemkul, 01/27/2009 01:06 PM

History

#1 Updated by Justin Lemkul over 10 years ago

Created an attachment (id=344)
Protein complex .gro file

#2 Updated by Justin Lemkul over 10 years ago

Created an attachment (id=345)
ligand .gro file

#3 Updated by Justin Lemkul over 10 years ago

(In reply to comment #0)

As reported to the gmx-users list:

http://www.gromacs.org/pipermail/gmx-users/2009-January/039211.html

The command that gives a segmentation fault is:

genbox -cp complex_newbox.gro -ci lig.gro -nmol 10

Values of -nmol < 4 work without error.

Version 3.3.3 on the same machine works fine. Version 4.0.3 works correctly on
an AMD64 machine, so the seg fault appears to be limited to my MacBook.

I should make it clear that I am using version 4.0.3 on the MacBook as well.

#4 Updated by David van der Spoel over 10 years ago

Fixed in CVS. Will be in 4.0.4.

Also available in: Atom PDF