Project

General

Profile

Bug #2858

Group scheme C kernels fail in complext tests

Added by Paul Bauer 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
core library
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Found this while trying to run https://gerrit.gromacs.org/#/c/9052/ on the 2019 regression tests

30803 Thread 15:
30803 Invalid write of size 4
30803 at 0x5CEFAE9: init_em(_IO_FILE*, gmx::MDLogger const&, char const*, t_commrec const*, gmx_multisim_t const*, t_inputrec*, MdrunOptions const&, t_state*, gmx_mtop_t*, em_state_t*, gmx_localtop_t*, t_nrnb*, t_forcerec*, t_graph**, gmx::MDAtoms*, gmx_global_stat**, gmx_vsite_t*, gmx::Constraints*, gmx_shellfc_t**, int, t_filenm const*) (minimize.cpp:369)
30803 by 0x5CF705D: gmx::Integrator::do_steep() (minimize.cpp:2441)
30803 by 0x5CE5312: gmx::Integrator::run(unsigned int, bool) (integrator.cpp:86)
30803 by 0x5D0B2BF: gmx::Mdrunner::mdrunner() (runner.cpp:1433)
30803 by 0x5D06B5E: gmx::mdrunner_start_fn(void const*) (runner.cpp:219)
30803 by 0x5D87FAE: tMPI_Thread_starter(void*) (tmpi_init.cpp:399)
30803 by 0x5D7F34B: tMPI_Thread_starter(void*) (pthreads.cpp:235)
30803 by 0x6262FA2: start_thread (pthread_create.c:486)
30803 by 0x66977EE: clone (clone.S:95)
30803 Address 0x4 is not stack'd, malloc'd or (recently) free'd

TODO: try to use 2019 with all SIMD support turned off by environment variable

md.log (18.3 KB) md.log Paul Bauer, 02/04/2019 03:25 PM
md.log (18.5 KB) md.log run with both GMX_NB_GENERIC=1 and GMX_DISABLE_SIMD_KERNELS=1 Paul Bauer, 02/04/2019 03:47 PM

Associated revisions

Revision c79af15e (diff)
Added by Paul Bauer 9 months ago

Fix segmentation fault in minimize

Fixes #2858

Change-Id: I9cf391be031979607d09087fa851eb644fb7e56e

History

#1 Updated by Paul Bauer 9 months ago

Might be related to #2813 as well.

#2 Updated by Paul Bauer 9 months ago

  • Related to Bug #2813: regressiontests/complex fails on Fedora30 with x86_64, i686 and other archs. added

#3 Updated by Mark Abraham 9 months ago

You can't turn off SIMD support with an environment variable. You can force the use of C-only kernels, or the use of the generic kernel. The point of this is to set the baseline for that the generic kernel works, thus whether https://gerrit.gromacs.org/#/c/9052/ is a reasonable idea.

#4 Updated by Paul Bauer 9 months ago

I misunderstood GMX_DISABLE_SIMD_KERNELS then, sorry.
I just ran the 2019 complex/urea test with the head of release-2019 and export GMX_DISABLE_SIMD_KERNELS=1, log attached.
No errors where encountered, so I guess the issue is somewhere else.

#5 Updated by Paul Bauer 9 months ago

Also does not happen with 2019 when adding export GMX_NB_GENERIC=1, log attached.

#6 Updated by Paul Bauer 9 months ago

So, the debugger tells me that state_global is not initialized for the child ranks of the simulation.

#7 Updated by Gerrit Code Review Bot 9 months ago

Gerrit received a related patchset '1' for Issue #2858.
Uploader: Paul Bauer ()
Change-Id: gromacs~master~I9cf391be031979607d09087fa851eb644fb7e56e
Gerrit URL: https://gerrit.gromacs.org/9085

#8 Updated by Paul Bauer 9 months ago

  • Target version changed from 2019.1 to 2020

Does not affect 2019 release branch.

#9 Updated by Paul Bauer 9 months ago

  • Affected version - extra info deleted (likely is something affected in 2019 as well)

#10 Updated by Paul Bauer 9 months ago

  • Related to deleted (Bug #2813: regressiontests/complex fails on Fedora30 with x86_64, i686 and other archs.)

#11 Updated by Paul Bauer 9 months ago

  • Status changed from New to Resolved

#12 Updated by Paul Bauer 9 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF