Project

General

Profile

Bug #2903

gmx wham doesn't compute profile with pull=angle-axis

Added by Kevin Boyd 7 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Given correct tprs and pull files on a set of umbrella windows maintained using angle-axis, the histogram is computed correctly but the profile is a bunch of Nans

gwham_error_sample.tar.gz (45.2 MB) gwham_error_sample.tar.gz Kevin Boyd, 06/02/2019 09:17 PM

Related issues

Is duplicate of GROMACS - Bug #2609: Evaluating PMF for angle rotations using gmx WHAMClosed

History

#1 Updated by Berk Hess 7 months ago

  • Status changed from New to Feedback wanted

Can you upload input and a command line?

#2 Updated by Kevin Boyd 5 months ago

Here's a simplified system, with a sample command run.

#3 Updated by Krzysztof Makuch 5 months ago

Kevin Boyd wrote:

Given correct tprs and pull files on a set of umbrella windows maintained using angle-axis, the histogram is computed correctly but the profile is a bunch of Nans

I have the same bug. It was reported by several people:
https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2016-August/108093.html
With possible solution for gromacs 2016:
https://redmine.gromacs.org/issues/2609
If solving it soon is a problem, could you please add en explanation inside gmx wham manpage, what exactly should we modify in xvg output files or in tpr binary to make it work? Also it might be a good idea to mention this bug in umbrella tutorials.

#4 Updated by Berk Hess 4 months ago

  • Is duplicate of Bug #2609: Evaluating PMF for angle rotations using gmx WHAM added

#5 Updated by Berk Hess 4 months ago

  • Status changed from Feedback wanted to Fix uploaded

I uploaded a fix, please check:
https://gerrit.gromacs.org/c/gromacs/+/11458

#6 Updated by Paul Bauer 4 months ago

  • Status changed from Fix uploaded to Closed

#7 Updated by Krzysztof Makuch 2 months ago

Berk Hess wrote:

I uploaded a fix, please check:
https://gerrit.gromacs.org/c/gromacs/+/11458

I had a moment to check it out and unfortunately it still doesn't work. As I understand (and as I've checked the part of the code mentioned in bug-fix) the change was incorporated in v. 2019.3. Histograms are still ok and profile is still column of '-nan'.

#8 Updated by Krzysztof Makuch 2 months ago

By the way, if we use pullf files instead of pullx we get bunch of sharp peaks instead of -nan.

#9 Updated by yujie liu about 1 month ago

I also found this bug in gromacs 2019.3, when I calculate the PMF of dihedral angle rotation. I pose a question on maillist https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2019-September/126614.html

Also available in: Atom PDF