Project

General

Profile

Task #2947

make an end to end test for membed

Added by Paul Bauer 6 months ago. Updated 28 days ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
testing
Target version:
Difficulty:
uncategorized
Close

Description

When using the membed functionality in mdrun, a segfault occurs after selecting the relevant groups.
The issue seems to be present since at least the original 2019 release and is still present at release-2019^HEAD.

Commands to reproduce

gmx mdrun -nt 1 -s gmembed.tpr -membed gmembed.dat -c pi_pH70_popc_further_solvate.pdb -mn index_before_gmembed.ndx -v

select group 1 for protein
select group 13 for POPC

index_before_gmembed.ndx (4.04 MB) index_before_gmembed.ndx Paul Bauer, 05/09/2019 03:47 PM
gmembed.tpr (11.5 MB) gmembed.tpr Paul Bauer, 05/09/2019 03:47 PM
gmembed.dat (902 Bytes) gmembed.dat Paul Bauer, 05/09/2019 04:25 PM

Associated revisions

Revision 63b3d45c (diff)
Added by Paul Bauer 5 months ago

Fix membrane embedding

Refactoring forgot to allocate some data, causing a segmentation fault.
More refactoring used wrong data, causing a crash further on.
Even more refactoring lead to invalid memory access.

Fixes #2947

Change-Id: I61ad3125102b50c0338e0935a75cd7b1de95bc3f

History

#2 Updated by Paul Bauer 6 months ago

  • Affected version - extra info changed from is present since 2018 to is present since 2019

Bisect shows that the bug got introduced in 8dd3c9ae88004054b3b112c23f747d27a19d8d29

#3 Updated by Paul Bauer 6 months ago

#4 Updated by Joe Jordan 6 months ago

Is there a plan to introduce an integration test on membed once the bug is fixed?

#5 Updated by Paul Bauer 6 months ago

I think there should be one :)
This hid actually another bug introduced in d4f85b613049e141c44f505b49e28e8b706b76ae

#6 Updated by Paul Bauer 6 months ago

There is still another bug further on in the tree :(

#7 Updated by Paul Bauer 6 months ago

it seems like the next bug was introduced in the merge fb755982116311bee2d1f9770678d221112e1ddb

#8 Updated by Mark Abraham 6 months ago

pro tip, write commit:2w3scxc9 and you get a link to the git repo behind redmine

#9 Updated by Paul Bauer 5 months ago

  • Status changed from New to Fix uploaded

#10 Updated by Paul Bauer 5 months ago

  • Status changed from Fix uploaded to Resolved

#11 Updated by Mark Abraham 5 months ago

  • Tracker changed from Bug to Task
  • Subject changed from mdrun segfaults when trying to use membed to make an end to end test for membed
  • Category set to testing
  • Status changed from Resolved to Accepted
  • Assignee deleted (Paul Bauer)
  • Target version changed from 2019.3 to 2020-beta1
  • Affected version - extra info deleted (is present since 2019)
  • Affected version deleted (2019.2)

membed will keep getting broken if nothing tests it

#12 Updated by Paul Bauer 28 days ago

  • Target version changed from 2020-beta1 to future

membed is currently disabled because it relied on the group scheme that has been removed for now

Also available in: Atom PDF