Project

General

Profile

Bug #2962

Segmentation fault, core dumped error

Added by Neena Eappen 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I saw this error on using gmx hbond command (described in detailed in the attached file)

Segmentation fault error.docx (16.1 KB) Segmentation fault error.docx Command line, output error Neena Eappen, 05/30/2019 05:05 AM
md_0_1.tpr (50.6 KB) md_0_1.tpr Neena Eappen, 05/30/2019 05:08 AM
md_0_1.trr (3.09 MB) md_0_1.trr Neena Eappen, 05/30/2019 05:08 AM

Associated revisions

Revision d886cc08 (diff)
Added by Paul Bauer 4 months ago

Add check for too many grid points in hbond

Fixes #2962

Change-Id: I61e80f8f254f1b5a0d968af087a87361fe4554ae

History

#1 Updated by Kevin Boyd 5 months ago

I looked into it, it looks like we're running out of memory. Your trr file box size is ~1000 nm, so I think something is wrong with your input files. Given that box size, the search grid has a size of ~13 billion elements.

Edit - confirmed this is the issue with Neena. We can close this, or add a check for excessive boxdims/gridding?

#2 Updated by Paul Bauer 5 months ago

  • Status changed from New to Fix uploaded
  • Assignee set to Paul Bauer
  • Target version set to 2019.3

Uploaded a check for too many interactions.

#3 Updated by Mark Abraham 5 months ago

One would need a hierarchical grid to cope with such extremes of scale, like the multipole methods' octtrees, which the implementation hasn't tried to do. So all we can do is give the clue that the box size to cutoff ratio is unsuitable

#4 Updated by Paul Bauer 4 months ago

  • Status changed from Fix uploaded to Resolved

#5 Updated by Paul Bauer 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF