Project

General

Profile

Bug #2974

position-restraints regressiontest fails on intel GPU

Added by Szilárd Páll 4 months ago. Updated 19 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
Affected version - extra info:
master
Affected version:
Difficulty:
uncategorized
Close

Description

Tested on i7-8550U + UHD 620 and i7-8559U + Iris Plus 655. Only reproduces without DD and nonbonded offloaded. The forces seem to be just slightly off.

Attached log and checkforce output.

md.log (20.3 KB) md.log Szilárd Páll, 06/11/2019 12:09 AM
checkforce.out (39.4 KB) checkforce.out Szilárd Páll, 06/11/2019 12:09 AM

History

#1 Updated by Szilárd Páll 4 months ago

Target tentative, unless we have a quick solution bump to next release.

#2 Updated by Mark Abraham 4 months ago

  • Target version changed from 2019.3 to 2019.4

I reproduced on my i7-7500U (neo), but without leads, we'll have to bump this for now

#3 Updated by Szilárd Páll 4 months ago

Mark Abraham wrote:

I reproduced on my i7-7500U (neo), but without leads, we'll have to bump this for now

Sure, I agree.

#4 Updated by Szilárd Páll 27 days ago

Still failing on both 2019 and master. I have no leads, but it can't be a PME issue as this test does not use PME.

#5 Updated by Mark Abraham 26 days ago

The logic about whether and how position restraints get run is pretty convoluted, so I could well believe that force contributions could be missed

#6 Updated by Berk Hess 26 days ago

The differences are very small though, so I wouldn't exclude a too tight tolerance either.

#7 Updated by Paul Bauer 19 days ago

  • Target version changed from 2019.4 to 2019.5

no fix in sight, bumped

Also available in: Atom PDF