Project

General

Profile

Bug #301

No deuterium order parameter output with g_order 4.0.3

Added by Sarah Witzke over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I want to obtain deuterium order parameters with g_order version 4.0.3:

Step to reproduce:
g_order -f dmpclim3-all.xtc -n dmpc_order.ndx -s dmpclim3-1.tpr -b 100000 -od dmpclim3_order_3.xvg

Last part of the screen output:
Taking z axis as normal to the membrane

Reading file dmpclim3-1.tpr, VERSION 4.0 (single precision)

Using following groups:

Groupname: C15_&_DMPC_C17_&_DMPC_C18_&_DMPC_C19_&_DMPC_C20_&_DMPC_C21_&_DMPC_C22_&_DMPC_C23_&_DMPC_C24_&_DMPC_C25_&_DMPC_C26_&_DMPC_C27_&_DMPC_C28_&_DMPC_C29_&_DMPC_C32_&_DMPC_C34_&_DMPC_C35_&_DMPC_C36_&_DMPC_C37_&_DMPC_C38_&_DMPC_C39_&_DMPC_C40_&_DMPC_C41_&_DMPC_C42_&_DMPC_C43_&_DMPC_C44_&_DMPC_C45_&_DMPC_C46_&_DMPC First atomname: C15 First atomnr 44

Reading frame 0 time 100000.008 Number of elements in first group: 3584

Reading frame 11000 time 210000.016

Read trajectory. Printing parameters to file

Actual result:
Now two order files are generated: The wanted dmpclim3_order_3.xvg and also order.xvg which I didn't request for. (Unlike version 4.0.2 where I only got sg-ang.xvg and sk-dist.xvg).

Unfortunately neither of the obtained .xvg files contain any order parameters:

dmpclim3_order_3.xvg:

  1. This file was created Sat Feb 28 20:02:09 2009
  1. by the following command:
  1. g_order -f dmpclim3-all.xtc -n dmpc_order.ndx -s dmpclim3-1.tpr -b 100000 -od dmpclim3_order_3.xvg

#

  1. g_order is part of G R O M A C S:

#

  1. Great Red Oystrich Makes All Chemists Sane

#

@ title "Deuterium order parameters"

@ xaxis label "Atom"

@ yaxis label "Scd"

@TYPE xy

order.xvg:

  1. This file was created Sat Feb 28 20:02:09 2009
  1. by the following command:
  1. g_order -f dmpclim3-all.xtc -n dmpc_order.ndx -s dmpclim3-1.tpr -b 100000 -od dmpclim3_order_3.xvg

#

  1. g_order is part of G R O M A C S:

#

  1. Great Red Oystrich Makes All Chemists Sane

#

@ title "Order tensor diagonal elements"

@ xaxis label "Atom"

@ yaxis label "S"

@TYPE xy

Expected result:
Only the file dmpclim3_order_3.xvg containing a list of order parameters

Build date and platform:
Build 2009-02-27 on Linux

History

#1 Updated by David van der Spoel over 11 years ago

From the mailing list I seem to recall that someone suggested to try 4.0.4 and that this solved the problem. Is that correct?

#2 Updated by David van der Spoel over 11 years ago

Apparently this was caused by an incorrect index file. If there is a way to improve documentation then please let us know. I'm closing this bug for now.

#3 Updated by Justin Lemkul over 11 years ago

I think some of the confusion comes from this line in the g_order help information:

"The index file has to contain a group with all equivalent atoms in all tails for each atom the order parameter has to be calculated for."

As written, it tends to suggest a single group, but yet the group must contain equivalent atoms. I would suggest changing that line to read something like:

"The index file should contain only the groups to be used for calculations, with each group of equivalent carbons along the relevant acyl chain in its own group."

Since the presence of non-equivalent groups (System, etc) also generates problems, it should be noted that these groups should be not be present. Would it be worthwhile to point to the wiki in some way, maybe through an error message if the index file is not correct? I did a step-by-step how-to for this sort of thing that I hope is helpful.

#4 Updated by David van der Spoel over 11 years ago

Thanks, this is now in the CVS version of the program.

Also available in: Atom PDF