Project

General

Profile

Task #3041

Task #3047: Set required versions for GROMACS 2021

Remove workaround for gcc bug 58265

Added by Eric Irrgang about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
core library
Target version:
-
Difficulty:
uncategorized
Close

Description

std::string is supposed to be no-throw-move-assignable, but wasn't, so we had some workaround cruft in GROMACS 2019. If/when we require sufficiently high versions of gcc's libstdc++, we can have simpler no-except move operation declarations. gcc 5.5 may be sufficient https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58265


Related issues

Related to GROMACS - Task #2831: Bump required version numbers of infrastructure for 2020New

History

#1 Updated by Mark Abraham about 1 month ago

If we would do this, then someone needs to analyze whether 5.5 is supported on whichever distro(s) drove the decision to retain gcc 5 as the earliest supported gcc. And update the install guide and docs accordingly.

IMO that isn't worth it, but we should note that when gcc 5.5 (or gcc 6+) is the minimum requirement, that this workaround is removed.

#2 Updated by Mark Abraham about 1 month ago

  • Related to Task #2831: Bump required version numbers of infrastructure for 2020 added

#3 Updated by Mark Abraham about 1 month ago

Note that I checked the gcc release notes, and 5.5 does fix it. However requiring a particular bug-fix version of gcc merely to resolve this minor code issue in GROMACS doesn't seem user friendly.

#4 Updated by Mark Abraham about 1 month ago

For example, we'd like to support Ubuntu 16.04 (whose lifetime ends in Q1 2021) in GROMACS 2020, and it seems to ship gcc 5.3 (https://packages.ubuntu.com/xenial/gcc)

#5 Updated by Eric Irrgang about 1 month ago

  • Parent task set to #3047

Agreed: this issue should depend on minimum required version, not drive it. Moving this to the next development cycle. Relevant when we require gcc >=6.

Also available in: Atom PDF