Project

General

Profile

Bug #3058

Error when using a large PME grid on a GPU

Added by Siyoung Kim about 1 month ago. Updated 18 days ago.

Status:
Feedback wanted
Priority:
Normal
Assignee:
-
Category:
mdrun
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

My system is quite large (1M atoms) and I am trying to run a simulation on the brand-new GPU cluster (4 Nvidia V100 GPUs and 2 Intel Skylake 6148 processors (40 cores per node)).
The running command is:
mpirun -np 4 gmx mdrun -deffnm md -ntomp 10 -nb gpu -pme gpu -npme 1 -gputasks 0123

I received the following error:
Error while launching kernel pme_solve_kernel: invalid argument

I found that this issue was discussed before (https://redmine.gromacs.org/issues/2779 ), but yet I experience the same issue. As discussed before, if I do not assign a PME task to GPUs, there is no problem. I attach input and output files.
I downloaded the latest gromacs (2018.3) and compiled it today.

If you could kindly let me know the configuration for the best performance, I would greatly appreciate it. Gromacs repeatedly complains that using 10 threads per rank is not a good idea.

Thanks!
Best,
Siyoung

md.mdp (1.12 KB) md.mdp Siyoung Kim, 08/14/2019 03:25 AM
md.tpr (26.7 MB) md.tpr Siyoung Kim, 08/14/2019 03:25 AM
slurm-61866150.out (3.51 KB) slurm-61866150.out Siyoung Kim, 08/14/2019 03:26 AM
md.log (20.6 KB) md.log Siyoung Kim, 08/14/2019 03:27 AM

History

#1 Updated by Szilárd Páll about 1 month ago

  • Category set to mdrun
  • Status changed from New to Feedback wanted

Please upgrade to the latest version, this should work in the 2019 release.

#2 Updated by Siyoung Kim 18 days ago

Szilárd Páll wrote:

Please upgrade to the latest version, this should work in the 2019 release.

Yes, it works in the 2019.3 release. Thank you.

Also available in: Atom PDF