Project

General

Profile

Task #3065

Agree and implement version support for GROMACS 2021

Added by Mark Abraham 30 days ago. Updated 29 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
uncategorized
Close

Description

As in #2899, we need to pick the minimum versions of any compilers/libraries/runtimes we wish to support in GROMACS 2021, e.g. C++ std, cmake, CUDA, oneAPI, gcc/icc/clang. We were a little pushy with such versions for GROMACS 2020, so my suggest is that we change very few of our minimum requirements (except declaring any requirements for things newly supported, like perhaps oneAPI). Of course, we should plan to test and support newer versions of existing things.


Related issues

Related to GROMACS - Task #2899: Update testing matrix versions for GROMACS 2020 releaseIn Progress
Is duplicate of GROMACS - Task #3047: Set required versions for GROMACS 2021New

History

#1 Updated by Mark Abraham 30 days ago

  • Related to Task #2899: Update testing matrix versions for GROMACS 2020 release added

#2 Updated by Eric Irrgang 30 days ago

  • Is duplicate of Task #3047: Set required versions for GROMACS 2021 added

#3 Updated by Mark Abraham 29 days ago

  • Status changed from New to Closed

Dupe

Also available in: Atom PDF