Project

General

Profile

Bug #3129

std::bad_alloc in pdb2gmx with Gromacs 2020 beta

Added by Koushik Choudhury 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Edited the BASEDIR='/nethome/koushikc' and BUILD_VERSIONS='2020-beta1' in build_gromacs.sh
sh_gromacs.sh.
This installed gromacs with different hardware configurations in 2020-beta1.
mkdir modulefiles
module use ~/modulefiles
cd modulefiles
Created a file 2020-beta1. Copied the contents of /opt/tcbsys/modulefiles/gromacs/2019.2 into it.
cd ..
copied /opt/tcbsys/modulefiles/get_simd and /opt/tcbsys/modulefiles/init_functions to /nethome/koushikc. cp /opt/tcbsys/modulefiles/get_simd . and /opt/tcbsys/modulefiles/init_functions .
mkdir sysconfig
cd sysconfig
cd
cd /opt/tcbsys/etc/modules/sysconfig/
cp * /nethome/koushikc/sysconfig/
module add 2020-beta1
gromacs 2020-beta1 gets loaded in the login node
gmx pdb2gmx -f 6p6w.pdb -o gmx_structure.pdb -p gmx_structure.top -i gmx_structure.itp -vsite hydrogens
Then I get the error after selecting the water model as bad alloc.

build_gromacs.sh (4.47 KB) build_gromacs.sh Koushik Choudhury, 10/11/2019 05:01 PM
get_simd (1.44 KB) get_simd Koushik Choudhury, 10/11/2019 05:27 PM
init_functions (1.52 KB) init_functions Koushik Choudhury, 10/11/2019 05:27 PM
6p6w.pdb (769 KB) 6p6w.pdb Koushik Choudhury, 10/11/2019 05:41 PM

Associated revisions

Revision 337d66fb (diff)
Added by Paul Bauer 6 months ago

Fix bug in preprocessing

Use of wrong vector caused out of bounds access.

Fixes #3129

Change-Id: I913c850a638f80d9d8d24708dc30170f448bc36c

History

#1 Updated by Paul Bauer 6 months ago

  • Subject changed from Gromacs 2020 beta to std::bad_alloc in pdb2gmx with Gromacs 2020 beta

we also need the input files for pdb2gmx to reproduce the bug

#2 Updated by Koushik Choudhury 6 months ago

The input pdb file for pdb2gmx.

#3 Updated by Eric Irrgang 6 months ago

  • Target version changed from 2020-beta1 to 2020-beta2

#4 Updated by Paul Bauer 6 months ago

  • Affected version changed from 2020-beta2 to 2020-beta1

What forcefield did you use? I need to know what steps you took to properly reproduce this!

#5 Updated by Koushik Choudhury 6 months ago

I used the charmm36 forcefield and TIP3P water model.

#6 Updated by Paul Bauer 6 months ago

  • Status changed from New to Fix uploaded
  • Assignee set to Paul Bauer

managed to find and fix this, fix is here: https://gerrit.gromacs.org/c/gromacs/+/13718

#7 Updated by Mark Abraham 6 months ago

Do the pdb2gmx tests not find this? Do we need to e.g. cover -vsite hydrogens?

#8 Updated by Paul Bauer 6 months ago

  • Status changed from Fix uploaded to Resolved

#9 Updated by Paul Bauer 6 months ago

  • Status changed from Resolved to Closed

#10 Updated by Paul Bauer 6 months ago

Mark Abraham wrote:

Do the pdb2gmx tests not find this? Do we need to e.g. cover -vsite hydrogens?

No, the tests didn't cover this (maybe also because the systems there are small and didn't overflow the vector).
I'll add a vsite test to them later today.

Also available in: Atom PDF