Project

General

Profile

Bug #314

Analysis tools cannot read past 1GB of large xtc files.

Added by Esben Friis over 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The analysis tools, such as trjconv or g_rmsf cannot read past 1GB of large xtc files. This is regardless whether the -b and -e options are used.

Steps to reproduce:
g_rmsf -f my_large_xtc_file.xtc -s my_topology.tpr -oq bfac.pdb

where the large xtc file is eg 3GB.

Actual results:
if the -b option is given a value that would correspond to more than about 1GB of the xtc file, the program exits with "specified frame does not exist or file is not seekable". (I know the xtc file is compressed in various ways, so the 1GB is only an estimate). If the program try to read past that frame, it exists silently and produces "correct" output, as if the xtc file ended here.

Expected results:
The analysis/conversion should run to the end of the xtc file.

Builds where the bug exists (here for g_rmsf):

Program g_rmsf, VERSION 4.0.3 (this build was from the debian package)
Program g_rmsf, VERSION 4.0.4 (build 2009-03-02)
Program g_rmsf, VERSION 4.0.99_development_20090307 (build 2009-04-15)

Platform: * amd64 * Ubuntu 8.04.2 * gcc 4.2.4 * autoconf 2.61

Other: * Bug is reproducible both on NFS mounted and directly attached file systems. * I have not thested this on other types of hardware or linux distros, so i have set the bug to "unconfirmed"

History

#1 Updated by David van der Spoel over 10 years ago

Sorry for waiting a year to answer this one, it is because we inadvertedly advocated that people set a bug to unconfirmed initially. These bugs don't show up automatically when we don't search for them explicitly.

This typically is a 32 bit issue, but since you explicitly state you have an amd64 OS that is unlikely. I suspect that this is related to bugs in libc related to the fseek library function that allows to search in files. Meanwhile there have been patches and workarounds for that, so I suspect and hope that this has been fixed.

Could you please test whether you still have this problem in gromacs-4.0.7?

#2 Updated by David van der Spoel over 10 years ago

This has probably been resolved in more recent versions already.

Also available in: Atom PDF