Project

General

Profile

Bug #3291

gmx-2020 tarball misses gmx-completion.bash

Added by Christoph Junghans about 1 month ago. Updated 12 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
build system
Target version:
Affected version - extra info:
Affected version:
Difficulty:
Close

Description

In gromacs-2020.tar.gz there is no gmx-completion.bash

$ls gromacs-{2019.5,2020}/src/programs/completion/
ls: cannot access 'gromacs-2020/src/programs/completion/': No such file or directory
gromacs-2019.5/src/programs/completion/:
gmx-completion.bash

This effectively make the completion build by default ("complete -o nospace -F _gmx_compl gmx") useless as _gmx_compl is defined nowhere.

Using -DGMX_BUILD_HELP=ON is a workaround.

Associated revisions

Revision 6ae6da63 (diff)
Added by Paul Bauer about 1 month ago

Revert "Exclude build-system files from CPack"

This reverts commit 617d7fb728eee44331d8f8f98fa644bc5921fcb3.

Caused #3291

This commit fixes #3291

Change-Id: Ib75dd9274c1822192d5ffd0ce458ab35a3406f11

History

#1 Updated by Paul Bauer about 1 month ago

  • Status changed from New to Accepted

I verified this on the current nightly 2020 release pipeline, but can't think why it would happen, currently investigating

#2 Updated by Paul Bauer about 1 month ago

it is also missing other files, with the bug introduced in 617d7fb728eee44331d8f8f98fa644bc5921fcb3
Going to work around this now

#3 Updated by Paul Bauer about 1 month ago

  • Assignee deleted (Paul Bauer)
  • Target version deleted (2020.1)
  • Difficulty deleted (uncategorized)

The issue is that we had to exclude the build directory because the Gitlab CI build was in source.

#4 Updated by Paul Bauer about 1 month ago

  • Category set to build system
  • Assignee set to Paul Bauer
  • Target version set to 2020.1

Didn't mean to remove the stuff there, was just tired

#5 Updated by Paul Bauer about 1 month ago

  • Status changed from Accepted to Fix uploaded

@Erik, we need to get the change to the GItlab runners done, so it is possible to change the git clone directory.
Patches are uploaded here https://gerrit.gromacs.org/c/gromacs/+/15081 and here https://gerrit.gromacs.org/c/gromacs/+/15283/, with the obvious pipeline failure due to missing gitlab runner support here https://gitlab.com/gromacs/gromacs-testing/pipelines/108577631

#6 Updated by Paul Bauer about 1 month ago

  • Status changed from Fix uploaded to Resolved

#7 Updated by Paul Bauer 12 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF