Project

General

Profile

Bug #331

Minimization error "Can not invert matrix, determinant ="

Added by Igor Leontyev over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The error appears each time when I am trying to minimize the structure
(protein+internal+external solvent). The initial structure is far away from the minimum (there are some large forces), but it should not be a problem, isn't it? I am able to do minimization of the same system by gmx3.3.1 version, but both particle (-pd) or domain (-dd) decomposition minimizations fail in 4.0.4 version. Below is the error message with particle decomposition (-pd):

Reading file CcO_4hcav_3Dch_E242side_OH-_O2-_PM.tpr, VERSION 4.0.4 (single
precision)
Steepest Descents:
Tolerance (Fmax) = 1.00000e+01
Number of steps = 1000

-------------------------------------------------------
Program mdrun, VERSION 4.0.4
Source code file: ../../include/vec.h, line: 706

Fatal error:
Can not invert matrix, determinant =


Related issues

Is duplicate of GROMACS - Bug #332: Can not invert matrix, determinant =Closed05/28/2009

Also available in: Atom PDF