Project

General

Profile

Bug #334

g_hbond gives error when used with trajectory with positional restraint.

Added by Krishna empty over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

g_hbond gives error when used with trajectory with positional restraint.

*************************************************************
Select a group: 12
Selected 12: 'SOL'
Select a group: 12
Selected 12: 'SOL'
Calculating hydrogen bonds in SOL (20949 atoms)

-------------------------------------------------------
Program g_hbond, VERSION 4.0.4
Source code file: gmx_hbond.c, line: 565

Fatal error:
Error in func_type Position Rest.
-------------------------------------------------------
I get this error only when using trajectory with positional restraint
during MD.
Is there any fix for this bug?

History

#1 Updated by David van der Spoel about 10 years ago

Which gromacs version is this in the 4.0.x series? I have seen this as well but only in development versions, not in released versions.

#2 Updated by Krishna empty about 10 years ago

Hi,
We installed VERSION 4.0.4. Is the problem rectified in newer versions?
Thanks

#3 Updated by David van der Spoel over 9 years ago

Sorry for not answering earlier, but has this been remedied in the most recent version 4.0.7?

#4 Updated by Krishna empty over 9 years ago

Great. Thanks.
I will install the latest version and let you know if there are any problems.

#5 Updated by Krishna empty over 9 years ago

Hi,

I installed 4.0.7, but this issue is not resolved in that version as well.
Let me know if there are any fixes. Thanks

Krishna

#6 Updated by Rossen Apostolov over 9 years ago

Assigning to Erik (Marklund).

#7 Updated by Erik Marklund over 9 years ago

I can't reproduce this error. Could you upload a tpr and a trr/xtc that generates this error?

Erik

#8 Updated by Erik Marklund over 9 years ago

Nevermind. I reproduced the error and found the cause. Will wait a day before I close the bug, because it should perhaps be patched in grompp instead/also and I'm waiting for some feedback on that thought.

Erik

#9 Updated by Erik Marklund over 9 years ago

I added a fix, although the real error may be in grompp, but I'm not sure. See http://bugzilla.gromacs.org/show_bug.cgi?id=428 for more info. Anyway, I'm closing this bug since all my test systems now go smoothly through the call to search_donors(), which is where the error arose.

Also available in: Atom PDF