Project

General

Profile

Bug #3384

Inconsisten labels in distance restraints can crash gmx disre

Added by David van der Spoel 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Probably earlier versions affected too.
Affected version:
Difficulty:
uncategorized
Close

Description

The gmx disre program used the labels in the distance restraint entries (see manual) as an index in internal arrays. This might lead to either memory errors or the program stopping due to uninitialized variables.

To reproduce, unpack the zip archive, check the location of the gmx executable and run the script forGromacs5.sh

gmx_disre_bug.zip (165 KB) gmx_disre_bug.zip David van der Spoel, 02/17/2020 11:07 PM

Associated revisions

Revision 45752960 (diff)
Added by David van der Spoel 7 months ago

Fixed bug in gmx disre due to inconsistency in input.

The gmx disre program used the labels in the distance restraint entries
(see manual) as an index in internal arrays. This might lead to either
memory errors or the program stopping due to uninitialized variables.

Fixes #3384

Change-Id: Ic2d77c3fd81547e030bf7ce21860a71e3adbb2b3

History

#1 Updated by David van der Spoel 7 months ago

  • Status changed from New to Resolved

#2 Updated by Paul Bauer 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF