Project

General

Profile

Bug #339

all-bonds option not constraining all bonds?

Added by Jussi Lehtola over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

IIUC setting
constraints = all-bonds
in the run .mdp file results in all bond lengths being constrained to the equilibrium value defined by the force field. Does this require some extra magic in the .top file?

My OPLS-AA alcohol simulations with "constraints = all-bonds" have resulted in largely the same results as for "constraints = h-bonds". Now having had a look at the bond length distributions it seems that the H bond lengths are correctly constrained, but the C-C bond lengths are not.

I've used Gromacs 4.0.3 for the simulations.

bonddists.tar.bz2 (6.69 KB) bonddists.tar.bz2 CA-CB bond length distributions in liquid ethanol as obtained by g_bond Jussi Lehtola, 07/14/2009 12:47 PM

History

#1 Updated by Berk Hess over 10 years ago

Please provide all the input files required to reproduce this problem.

Berk

#2 Updated by Jussi Lehtola over 10 years ago

This is a bit odd.

When I look at the C-C bond in ethanol with an index file I see that it is constrained with all-bonds (normal distribution with std 0.000410457, compared to 0.00326475 with 'none' and 0.00330772 with 'h-bonds').

However the distribution in bonds.xvg given by g_bond is identical for 'h-bonds' and 'all-bonds': there are sharp peaks at 0.95 Å and 1.1 Å and a bell curve at roughly 1.77Å with a standard deviation of 0.6 Å.

#3 Updated by Jussi Lehtola over 10 years ago

Created an attachment (id=384)
CA-CB bond length distributions in liquid ethanol as obtained by g_bond

#4 Updated by Berk Hess over 10 years ago

Can it be that you have a mistake in your index file forr g_bond?
A distance of 0.177 nm is far too long for a C-C bond.
I suspect you are looking at an H-C distance.

Berk

#5 Updated by Jussi Lehtola over 10 years ago

(In reply to comment #4)

Can it be that you have a mistake in your index file forr g_bond?
A distance of 0.177 nm is far too long for a C-C bond.
I suspect you are looking at an H-C distance.

Yes, that is what I would think too.

It just came to me that g_hbond has a mandatory index file input. In the run folder I had the file index.ndx that contained the default groups System and EtOH. When run on either of these groups g_hbond produces the distances of all sorts of combinations of pairs.

It would be nice if g_bond gave some warning (or an error, even) about nonexisting bonds if the atoms don't have a bond in the topology..

Thanks for your help, and sorry for the trouble!

#6 Updated by Berk Hess over 10 years ago

The problem is more in the name of the program.
g_bond simply determines distance distributions, not bond distributions.
One can use it for any pair of atoms.

Berk

Also available in: Atom PDF