Project

General

Profile

Bug #367

make_ndx throws a fatal error if you suspend (Ctrl-Z) and resume

Added by Peter Kasson about 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Git-current gromacs on OS/X throws a fatal error in make_ndx if you suspend and resume. My git image as of Aug 30 doesn't do this, so I'm suspecting something between then and now, perhaps with the selection library?

^Z

[1]+ Stopped /Desktop/Software/gromacs/src/tools/make_ndx -f foo -o bar
DN0a20fab3:ha_bilayer kasson$ fg
/Desktop/Software/gromacs/src/tools/make_ndx -f foo -o bar

-------------------------------------------------------
Program make_ndx, VERSION 4.0.99_development_20090605
Source code file: /Users/kasson/Desktop/Software/gromacs/src/tools/make_ndx.c, line: 894

Fatal error:
Error reading user input
For more information and tips for trouble shooting please check the GROMACS website at
http://www.gromacs.org/Documentation/Errors
-------------------------------------------------------

History

#1 Updated by Teemu Murtola about 10 years ago

I've never changed any code in make_ndx, so I don't think this has anything to do with the selection library. I can reproduce the bug on my Mac OS X, but not on Linux. I also seem to get the same error on the Aug 30 version of git master.

It seems that for some reason, fgets() is failing when it gets suspended. So I would guess this has something to do with system libraries and/or configure options? Maybe you could check whether you used exactly the same options for configure to build both the versions to track down whether this could be the cause (note that in between, --enable-apple-64bit has been replaced by autodetection).

#2 Updated by David van der Spoel over 9 years ago

Can this be closed? Apples libc is full of bugs anyway (running three apple boxes on my desk anaway).

#3 Updated by Sander Pronk over 9 years ago

David & Teemu are right; this is a Mac OS X libc issue.

Also available in: Atom PDF