Project

General

Profile

Bug #387

vsite and particle decomposition

Added by serena donnini almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=418)
tpr file with virtual sites (oligomeric protein -no solvent)

I had a problem when running with virtual sites (-vsite hydrogens) and
particle decomposition (mdrun -pd) on more than one processor with
gromacs 4.0.7. I could run without problems the same files without
virtual site description. The error message looks like this:

[node036:28870] * An error occurred in MPI_Wait
[node036:28870]
on communicator MPI_COMM_WORLD
[node036:28870]
MPI_ERR_TRUNCATE: message truncated
[node036:28870] *
MPI_ERRORS_ARE_FATAL (goodbye)

It seems that the error message comes from move_cgcm() in
sim_util.c, line 157, but the cause could as well
be MPI communication that happens before move_cgcm.

topol.tpr (5.89 MB) topol.tpr tpr file with virtual sites (oligomeric protein -no solvent) serena donnini, 01/20/2010 09:27 AM

History

#1 Updated by Berk Hess almost 11 years ago

I fixed the bug by merging in the git master particle decomposition
vsite communication code, which was modified and correct.

Berk

#2 Updated by Berk Hess almost 11 years ago

This bug has been fixed.

Berk

Also available in: Atom PDF