Project

General

Profile

Bug #395

Missing lib dependencies for libgmxpreprocess

Added by Christoph Junghans almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=426)
patch to make "--as-needed" work

Try to build gromacss from git head with LDFLAGS="-Wl,--as-needed".
It will fail.

There is a lib dependencies for libgmxpreprocess missing.
A patch to fix that is attached.

as-needed.patch (524 Bytes) as-needed.patch patch to make "--as-needed" work Christoph Junghans, 02/09/2010 02:18 PM

Associated revisions

Revision b7aaec78 (diff)
Added by Christoph Junghans over 9 years ago

Dep issues with libgmxpreprocess (#392, #395).

libgmxpreprocess now depends on libmd, and is built/installed with
make mdrun/install-mdrun.

History

#1 Updated by Teemu Murtola over 9 years ago

Applied patch to git master.

Also available in: Atom PDF