Project

General

Profile

Bug #400

problem with freezing group and temperature coupling

Added by srinivasa rao over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

I am getting problems in running the GROMACS 4.0.5 with freezing option.

I would like to freeze all water molecules present after 18A (for my current input attached ed with this email) from the center of the box. I have created two groups first one is all waters present after 18 A, and the second one all but not the index of first selected.

I have separated the temperature coupling for non-freezing and freezing groups and submitted for a 3ns mdrun. In the log file it shows me the nrdf value for both non freezing and freezing groups as zero.

I have not applied pressure coupling.

Herewith i am attaching all my input files. Please help me to solve the problem.

Thanks
Srinivs.

url (44 Bytes) url in this url there is link with the name gromacs files, all files can be downloades from here. srinivasa rao, 03/06/2010 11:19 PM
gromcs_bugr.tar.gz (622 KB) gromcs_bugr.tar.gz tar file contained all files that i have used for simulations. srinivasa rao, 03/06/2010 11:35 PM
pep_ion.gro (965 KB) pep_ion.gro gromacs coordinates srinivasa rao, 03/06/2010 11:39 PM
md.mdp (1013 Bytes) md.mdp mpd config file srinivasa rao, 03/06/2010 11:39 PM
index.ndx (375 KB) index.ndx index file srinivasa rao, 03/06/2010 11:40 PM
Freeze-group-Tmp2.txt (58.3 KB) Freeze-group-Tmp2.txt freeze group srinivasa rao, 03/06/2010 11:40 PM
non-freez-Tmp1.txt (15.5 KB) non-freez-Tmp1.txt non freeze group srinivasa rao, 03/06/2010 11:41 PM
par_of_log_file.log (5.09 KB) par_of_log_file.log log file srinivasa rao, 03/06/2010 11:42 PM
pep_ion.top (36.5 KB) pep_ion.top topology file srinivasa rao, 03/06/2010 11:42 PM
pep_md.tpr (551 KB) pep_md.tpr tpr file generated with grompp srinivasa rao, 03/06/2010 11:43 PM
readir.c (67.1 KB) readir.c fixed src/kernel/readir.c Berk Hess, 03/08/2010 09:40 AM

History

#1 Updated by Berk Hess over 10 years ago

No files are attached.
Please use the "Add an attachment" link above.

Berk

#2 Updated by srinivasa rao over 10 years ago

Created an attachment (id=431)
in this url there is link with the name gromacs files, all files can be downloades from here.

Dear Berk,

I have put all files in a tar file, and it is available on my web i have given the link to those files here. Sorry for the delay.

Thanks
Srinivas.

#3 Updated by Erik Lindahl over 10 years ago

Hi Srinivas,

It's critical for us to be able to track bugs and reproduce them even years from now, so it's important for us to have the files as real attachments saved on the server!

Cheers,

Erik

#4 Updated by srinivasa rao over 10 years ago

Created an attachment (id=432)
tar file contained all files that i have used for simulations.

#5 Updated by srinivasa rao over 10 years ago

Created an attachment (id=433)
gromacs coordinates

#6 Updated by srinivasa rao over 10 years ago

Created an attachment (id=434)
mpd config file

#7 Updated by srinivasa rao over 10 years ago

Created an attachment (id=435)
index file

#8 Updated by srinivasa rao over 10 years ago

Created an attachment (id=436)
freeze group

#9 Updated by srinivasa rao over 10 years ago

Created an attachment (id=437)
non freeze group

#10 Updated by srinivasa rao over 10 years ago

Created an attachment (id=438)
log file

#11 Updated by srinivasa rao over 10 years ago

Created an attachment (id=439)
topology file

#12 Updated by srinivasa rao over 10 years ago

Created an attachment (id=440)
tpr file generated with grompp

#13 Updated by Berk Hess over 10 years ago

Created an attachment (id=441)
fixed src/kernel/readir.c

This src/kernel/readir.c fixes the bug.

Berk

#14 Updated by Berk Hess over 10 years ago

I fixed this bug already in git master. At first I thought this bugzilla
was not due to that bugfix, but I now realize it is, so I backported
the fix to the 4.0 release branch.

Berk

Also available in: Atom PDF