Project

General

Profile

Bug #411

LINCS errors or segfaults in 2DPME-merged gromacs with threads

Added by Peter Kasson over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=452)
tpr to provoke error

Hi,
I'm getting LINCS errors or segfaults in git-current Gromacs when I run multiple threads but not when I use -nt 1. I'm attaching a tpr; I get this somewhat stochastically but typically in the first 200 steps.

The build system for this was merlot (OS/X 10.6.3; autoconf + gcc + fftw3).
PS I have an April 9 double-precision build that runs this tpr fine with multiple threads.

Thanks,
--Peter

test.tpr (2.15 MB) test.tpr tpr to provoke error Peter Kasson, 05/07/2010 06:54 PM

History

#1 Updated by Sander Pronk over 9 years ago

Check out the latest commit. I think it was an uninitialized index in solve_pme_yzx(), but I'm not 100% sure (i simply can't reproduce the crash any more).

#2 Updated by Peter Kasson over 9 years ago

Looks good in testing so far, thanks.

Also available in: Atom PDF