Project

General

Profile

Bug #480

PDB2GMX Dies with Dirent issues

Added by Kyle Beauchamp over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I compiled the July 25 GIT using cmake. mdrun works fine; however, pdb2gmx exits with dirent issues. Note that running "pdb2gmx -h" does NOT reproduce the bug--you either need to run "pdb2gmx" or "pdb2gmx -f test.pdb"

My build was pretty standard--I started from a fresh GIT. The only changes to default cmake options were SSE and disable testing.

Ubuntu 10.04 64bit system.

-------------------------------------------------------
Program pdb2gmx, VERSION 4.0.99-dev-20100725-8d024
Source code file: /opt/gromacs/gromacs-july25/src/gmxlib/futil.c, line: 552

Fatal error:
Source compiled without POSIX dirent or windows support - cannot scan directories.
In the very unlikely event this is not a compile-time mistake you could consider
implementing support for your platform in futil.c, but contact the developers
to make sure it's really necessary!

For more information and tips for troubleshooting, please check the GROMAC

out.log (7.36 KB) out.log log of cmake ./ Kyle Beauchamp, 07/26/2010 08:46 PM

History

#1 Updated by Kyle Beauchamp over 9 years ago

For a quick (and wrong) fix, I added #define HAVE_DIRENT_H to my src/config.h

#2 Updated by Erik Lindahl over 9 years ago

Hi,

Could you:

1. Attach your config.log
2. Check if dirent.h is physically present on you system. If so, where?

#3 Updated by Kyle Beauchamp over 9 years ago

Created an attachment (id=501)
log of cmake ./

#4 Updated by Kyle Beauchamp over 9 years ago

I don't have a config.log, so I did cmake ./ > out.log I am attaching the file
out.log--FYI, it says dirent is found. IMHO, the problem is that nothing is
getting written to src/config.h.

kyleb@kyleb-desktop:~$ ls /usr/include/dirent.h
/usr/include/dirent.h

kyleb@kyleb-desktop:/opt/gromacs$ git clone git://git.gromacs.org/gromacs.git
gromacs-july25-test
cd gromacs-july25-test
ccmake ./
make -j6

src/kernel/pdb2gmx
Fatal error:
Source compiled without POSIX dirent or windows support - cannot scan
directories.
In the very unlikely event this is not a compile-time mistake you could
consider
implementing support for your platform in futil.c, but contact the developers
to make sure it's really necessary!

#5 Updated by Erik Lindahl over 9 years ago

Hm. config.h.cmakein seems to have been a few commits behind - I think we keep forgetting we have to add the headers manually there too, since it is automatic with autoconf. I've pushed a new version into git, see if that solves it for you.

#6 Updated by Kyle Beauchamp over 9 years ago

Your updates solved the problem. Thanks. I'm moving this to fixed.

Also available in: Atom PDF