Project

General

Profile

Bug #491

Constraints defined for a bond not working during simulation.

Added by nrdhumal empty over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

If you defined constraints (constraints difined in .itp file) for a perticular bond and run the simulation with this constraints.After the simulatons gets over I have noticed that bond distance didn't remain constant and it oscillate with 0.3 to 0.5 nm.
Example. If I put the constraints for AB bond should be 0.35 nm. After ploting g_dist I noticed it oscillate bewteen 1.1 nm to 5 nm. Expected is AB should remain constant 0.35 nm through out the simulation.

History

#1 Updated by Berk Hess over 9 years ago

I seriously doubt there is an issue with constraints,
since nearly every simulation uses these.
But if you really think there is an issue,
please attach all the input files for grompp so we can
try to reproduce the problem.

Berk

#2 Updated by Berk Hess over 9 years ago

But you have
constraints=none
in your MD nvt-400.mdp file!
Your minim.mdp does have constraints turned on.

Please check your input before filing a bugzilla.

Berk

#3 Updated by Berk Hess over 9 years ago

Please keep the correspondence on bugzilla.

You might have a constraint in solute.itp,
but none of the files you mailed includes solute.itp.

Berk

#4 Updated by Berk Hess over 9 years ago

Please answer on the bugzilla.gromacs.org page,
there is a link in the mail that you can click.

You already attached solute.itp before.
The problem is that nor the top file, neither one of the itp
files included in there includes solute.itp.
You can define a constraint in solute.itp, but if the file
is not used, the constraint is not used.

Berk

#5 Updated by Berk Hess over 9 years ago

This is almost certainly not a bug in Gromacs,
but an error in your files, or more likely due to a mistake
in your procedure to set up the simulation.
I don't have the time to look into the problems of users.

Please check your input, several options:
If necessary, read the documentation,
double check the topology setup,
use grompp -pp and check the processed output for the [ constraint ]
(and make the the moleculetype matches the one in your [ system ].
run gmxcheck -s1 ... -s2 ... on the tpr with and without constraint
to see what the differences are.

Only when you have triple checked everything and still have problems,
first search the gmx-users list and then post there if you did
not find a solution.

Berk

#6 Updated by Berk Hess over 9 years ago

One more hint:
the top file your mailed does not have the ABC moleculetype
listed in the [ molecules ] section at the end.

Berk

Also available in: Atom PDF