Project

General

Profile

Bug #495

pdb2gmx crashes when compiled with icc

Added by Szilárd Páll over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

If compiled with icc (tested with v 11.1 20100203) pdb2gmx instantly crashes, but not with gcc (tested with 4.4.1).

Running it through valgrind shows a large number of errors in the arguments parsing.

--

Originally reported here: http://lists.gromacs.org/pipermail/gmx-users/2010-August/052990.html

History

#1 Updated by Rossen Apostolov over 9 years ago

It doesn't crash when compiled in single precision but complains about missing forcefields:

$ ../../gmx-build-autoconf/src/kernel/pdb2gmx -f bpti.pdb
No force fields found (files with name 'forcefield.itp' in subdirectories ending on '.ff')

But the problem is not in the FF, it works with the gcc compiled one.

#2 Updated by Berk Hess over 9 years ago

Rossen, did you run valgrind on the single precision pdb2gmx?

Berk

#3 Updated by Rossen Apostolov over 9 years ago

The bug surfaced after compiling it without any optimization - there was a missing NULL at the end of an ENUM. Kudos to Teemu for spotting it.

Fixed in 0a31a047f429e0c62ed7b098d4987cc5f15942b1.

Also available in: Atom PDF