Project

General

Profile

Bug #496

coulomb with nb_generic is wrong

Added by Roland Schulz over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Running standard lysozyme benchmark with PME and GMX_NB_GENERIC=1 gives totally wrong Coulomb energies. I compiled with ICC 11.1.

History

#1 Updated by Berk Hess over 9 years ago

This is not really supposed to work (yet), exclusions do not work properly.
The cg loops assume all intra-cg interactions are excluded and no
inter-cg interactions are excluded.
We should add this to the documentation and maybe also to some log print.

Berk

#2 Updated by Berk Hess over 9 years ago

Oops, my last comment was for GMX_NBLISTCG.
I have added a check for the exclusions for the cg-cg loops.

I have reproduced the GMX_NB_GENERIC with a pure water system.

Berk

#3 Updated by Berk Hess over 9 years ago

Ah, I realized again that this is because of the water loops.
You should also use GMX_NO_SOLV_OPT, I have mailed this twice
to gmx-users.
We should probably automatically turn this on when GMX_NB_GENERIC is set.
The check should then be moved to forcerec.c.

Berk

#4 Updated by Berk Hess over 9 years ago

I moved the GMX_NB_GENERIC check to forcerec.c and let it turn
off the solvent optimization.

Berk

Also available in: Atom PDF