Project

General

Profile

Bug #507

Segmentation fault when analyze a trajectory which does not have same number of atoms as the .tpr file

Added by Xiaohu Hu over 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

So far I experienced that several tools trjconv, g_rms, grmsf, g_covar, g_anaeig crash with a segmentation fault if the trajectory read in does not have the same atom number as the atom number in the .tpr file. I realized it when I tried to analyze my trajectories of protein simulation after I removed the water molecules from them. It seems to be a systematic problem. I can do the same analysis without any problems with the older version of gromacs tools, i. e. version 4.0.7. The older version would carry out the calculation normally but with a warning that the trajectory does not have the same number of atoms as the total atom numbers specified in the .tpr file.

History

#1 Updated by David van der Spoel over 9 years ago

Did you remove the water from the trajectory? That should work, but not the other way around. Please upload a small example with only a few frames in the trajectory and give an exact command line that allows us to reproduce it.

#2 Updated by Xiaohu Hu over 9 years ago

Hi, I used trjconv to write out the trajectory from the original trajectory that only contains the protein. If I want to do analysis on this protein-only trajectory combined with the .tpr file, then it crashes with a segmentation fault. But it works perfectly with older version of the gromacs tools. I will upload some example files to demonstrate it shortly.

(In reply to comment #1)

Did you remove the water from the trajectory? That should work, but not the
other way around. Please upload a small example with only a few frames in the
trajectory and give an exact command line that allows us to reproduce it.

#3 Updated by Berk Hess about 9 years ago

Strange that we did not notice this bug before, but I guess that's what beta testing if for...
I fixed it for the next beta release.

Berk

#4 Updated by Maria Pechlaner almost 8 years ago

I have the same problem, using gromacs 4.5.5.
It does not happen systematically: I have a number of simulations where the only difference is the starting conformation of my macromolecule, which also leads to slightly varying cell volumes, numbers of ions and water molecules.
I write out the .xtc trajectories without water, and when I run g_rms in some cases I get a segmentation fault after g_rms prints the "WARNING: topology has 78959 atoms, whereas trajectory has 1682", in other cases I don't.

#5 Updated by David van der Spoel almost 8 years ago

  • Assignee deleted (Erik Lindahl)

As a rule it is a good idea to have the same number of waters and ions for the same macromolecule.

Are you sure that you use the tpr corresponding to the xtc - with only water removed? Because if the number of ions also changes anything can happen. Please provide examples of short trajectories (two frames is enough) and corresponding tpr file.

Also available in: Atom PDF