Project

General

Profile

Bug #508

REMD problem (gmx4.5 beta3)

Added by Changwon Yang over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

mpirun -n 4 mdrun_mpi_d -v -deffnm md_ -multi 4 -replex 250

####error message#####
starting mdrun 'Protein in water'
500000 steps, 1000.0 ps.
starting mdrun 'Protein in water'
500000 steps, 1000.0 ps.
starting mdrun 'Protein in water'
500000 steps, 1000.0 ps.
starting mdrun 'Protein in water'
500000 steps, 1000.0 ps.
step 200, will finish Sun Aug 15 18:10:06 2010[localhost:31930] * Process received signal
[localhost:31930] Signal: Segmentation fault (11)
[localhost:31930] Signal code: Address not mapped (1)
[localhost:31930] Failing at address: (nil)
[localhost:31931]
Process received signal
[localhost:31931] Signal: Segmentation fault (11)
[localhost:31931] Signal code: Address not mapped (1)
[localhost:31931] Failing at address: (nil)
[localhost:31930] [ 0] /lib64/libpthread.so.0 [0x36e9e0eb10]
[localhost:31930] [ 1] mdrun_mpi_d(replica_exchange+0x1136) [0x42a446]
[localhost:31930] [ 2] mdrun_mpi_d(do_md+0x48a8) [0x433ca8]
[localhost:31930] [ 3] mdrun_mpi_d(mdrunner+0x11f1) [0x42f181]
[localhost:31930] [ 4] mdrun_mpi_d(main+0x9f1) [0x438101]
[localhost:31930] [ 5] /lib64/libc.so.6(_libc_start_main+0xf4) [0x36e921d994]
[localhost:31930] [ 6] mdrun_mpi_d [0x420359]
[localhost:31930]
End of error message
[localhost:31931] [ 0] /lib64/libpthread.so.0 [0x36e9e0eb10]
[localhost:31931] [ 1] mdrun_mpi_d(replica_exchange+0x1136) [0x42a446]
[localhost:31931] [ 2] mdrun_mpi_d(do_md+0x48a8) [0x433ca8]
[localhost:31931] [ 3] mdrun_mpi_d(mdrunner+0x11f1) [0x42f181]
[localhost:31931] [ 4] mdrun_mpi_d(main+0x9f1) [0x438101]
[localhost:31931] [ 5] /lib64/libc.so.6(
_libc_start_main+0xf4) [0x36e921d994]
[localhost:31931] [ 6] mdrun_mpi_d [0x420359]
[localhost:31931]
End of error message *
--------------------------------------------------------------------------
mpirun noticed that process rank 2 with PID 31930 on node localhost.localdomain exited on signal 11 (Segmentation fault).

MPI library : Openmpi 1.3.3 or mpich2-1.2.1p1
C compiler : intel 11.0

md.tar (2.22 MB) md.tar REMD problem (gmx4.5 beta3) Changwon Yang, 08/15/2010 08:41 AM

History

#1 Updated by Changwon Yang over 9 years ago

Created an attachment (id=514)
REMD problem (gmx4.5 beta3)

#2 Updated by Berk Hess over 9 years ago

I think this is caused by a bug that I just fixed:
commit bddb13701ead6dc4b328e81431161e823edae2be

Berk

Also available in: Atom PDF