Project

General

Profile

Bug #524

Extra atoms not removed from pdb file

Added by Erik Lindahl about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The attached PDB file has an N-terminal PRO with two hydrogens names H2 & H3.

pdb2gmx (correctly) assigns an NH2+-terminus, but then goes ahead and adds H1 - without removing H3.

The end result is that there is one hydrogen too much, and incorrect (non-integer charge).

This is apparently present in 4.0.7 too.

hiv_nel.pdb (169 KB) hiv_nel.pdb pdb file to reproduce result. Try with pdb2gmx and choose OPLS-AA. Erik Lindahl, 08/26/2010 03:23 PM

History

#1 Updated by Erik Lindahl about 9 years ago

Created an attachment (id=525)
pdb file to reproduce result. Try with pdb2gmx and choose OPLS-AA.

#2 Updated by Erik Lindahl about 9 years ago

Fixed by commit 11e839e7ea1828b2233894ba9ff2d8202263cd2f.
There was some old code lying around that made an exception for N-terminal hydrogens, but since these are now properly added in the RTP I see no reason why we should not apply the same rule for those.

Also available in: Atom PDF