Project

General

Profile

Bug #543

CMake Fails on Windows: winthreads.c missing.

Added by Kyle Beauchamp about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

This refers to the Tar on the downloads page:

ftp://ftp.gromacs.org/pub/gromacs/gromacs-4.5.1.tar.gz

Using standard settings except for MKL. MSVC 2008, WinXP, CMake 2.9. The Sept. 1 GIT worked without error, but the tarred version fails cmake with the errors posted below.

I think the problem is related to winthreads.c being missing from the 4.5.1.tar.gz archive:

cd gromacs-4.5.1/
ls src/gmxlib/thread_mpi/win*
ls: cannot access src/gmxlib/thread_mpi/win*: No such file or directory

Could NOT find LibXml2 (missing: LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR)
Loaded CMakeASM-NASMInformation - ASM-NASM support is still experimental, please report issues
Configuring done
CMake Error in src/gmxlib/CMakeLists.txt:
Cannot find source file "winthreads.c". Tried extensions .c .C .c++ .cc
.cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp .hxx .in .txx

History

#1 Updated by Sander Pronk about 9 years ago

Fixed in d98205807bc2e09d281f20a77eef6c5eec6e1e0f. Sorry for the confusion: I didn't realize the Makefile.am are used as source for what to include in the distribution.

Also available in: Atom PDF