Project

General

Profile

Bug #566

mdrun sd Segmentation fault

Added by Thomas Mustard about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=538)
A zip file of one FEP job that includes lambda 0-1

Running several free energy perturbation (FEP) runs to further understand how I should set up my larger production runs and I keep getting errors that I cannot find in the gmx-user email or anywhere specifically online.

Error 1:
I get this error on three of my four runs.The system is a single rna in a water box. Amber03 and tip3p. Two are cyt an the other two are gua. I get through energy minimization (steep) and I fail on positional restriction sd. I can continue on if I turn -dlb no but I get error 2 below.

Some interactions seem to be assigned multiple times...

This seemed to occur after a restart of a failed job due to loss of HDD available space. I am trying to reproduce this error.

Error 2:

This error only comes up if I turn "-dlb no" in the above step. I get through energy minimisation (steep), positional restraint (sd) and I then fail on step 0 of my production run (sd).

Getting Loaded...
Reading file monomer_md.tpr, VERSION 4.5.1 (single precision)
Starting 2 threads
Loaded with Money

Making 1D domain decomposition 2 x 1 x 1

Back Off! I just backed up dhdl.xvg to ./#dhdl.xvg.1#
starting mdrun 'Protein in water'
625000 steps, 2500.0 ps.
step 0/opt/gridengine/default/spool/compute-0-15/job_scripts/1877: line 50: 28413 Segmentation fault /home/tjmustard/bin/Gromacs/gromacs-4.5.1-runfolder/bin/g4.5.1-mdrun -v -s monomer_md.tpr -o monomer_md.trr -c monomer_after_pr.gro -g md.log -e md.edr -cpi state_md.cpt -cpo state_md.cpt -dlb no

Both jobs are running on a linux cluster running SGE. I have had several jobs finish on this cluster with no problems. I am also running a slightly modified 4.5.1 version. The topsort.c file in the source code was missing a line of code and I was getting Improper Dihedral in ip_pert errors. I have run several methane hydration FEP's go to completion with very similar FEP results. I am hoping this is a small problem that can be fixed easily.

I will attach a compressed folder of my project.

FEP-Monomer-Reg.zip (399 KB) FEP-Monomer-Reg.zip A zip file of one FEP job that includes lambda 0-1 Thomas Mustard, 09/20/2010 10:04 PM
Monomer-000.zip (8.52 MB) Monomer-000.zip A failed job Thomas Mustard, 09/21/2010 05:57 PM

History

#1 Updated by Berk Hess about 9 years ago

Could you attach the input files for grompp for the/a crashing run?
I don't want to try to find out how to run the equilibration and also
possibly run the risk of generating slightly different states.

Thanks,

Berk

#2 Updated by Thomas Mustard about 9 years ago

Created an attachment (id=541)
A failed job

This job failed and the joblog is the monomer.joblog file. Also included is the md.mdp file.

#3 Updated by Berk Hess about 9 years ago

Your run crashes because in md.mdp your have:
define = -DFLEXIBLE ; =
Flexible water crashes with a timestep of 4 fs (and you should
never use flexible water anyhow, except problematic energy minimization).

Berk

#4 Updated by Berk Hess about 9 years ago

Also constraints=none is a problem with dt=4 fs.
I have now added a warning or note in grompp for 4.5.2 when the time step
is large compared to bond vibrations (with a hint about turning in constraints).
This avoids mistakes for the users and it avoids extra work for developers
for tracking down the cause of "non-bugs".

Berk

#5 Updated by Thomas Mustard about 9 years ago

Thank you

Also available in: Atom PDF