Project

General

Profile

Bug #579

nstcalcenergy = -1 leads to wrong pressure

Added by David van der Spoel almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have confirmed this as a bug.
In 4.0.5 (which I had handy) the density is constant
Density (SI) 999.554 3.82377 3.80651 0.0628345 1.25694

In 4.5.1 with 4.0.5 tpr file it is as you say:
Density 995.277 1.3 4.32625 -1.24517 (kg/m3)

In 4.5.1 with 4.5.1 tpr file I get
Density 709.919 66 137.824 -467.285 (kg/m3)

Now the differences in the tpr files are revealing:
[anfinsen:test-volume-drift] % gmxcheck s1 topol405.tpr -s2 topol.tpr
<snip>
Note: tpx file_version 58, software version 73
Reading file topol.tpr, VERSION 4.5.1
%ci-21e8a32 (single precision)
comparing inputrec
inputrec->nstcalcenergy (1 - 10)
inputrec->rgbradii (2.000000e+00 - 1.000000e+00)
inputrec->sa_surface_tension (2.092000e+00 - 2.050160e+00)
inputrec->sc_sigma_min (0.000000e+00 - 3.000000e-01)
inputrec->nstdhdl (1 - 10)
inputrec->separate_dhdl_file (0 - 10)
<snip>

After setting nstcalcenergy = 1 I get
Density 996.894 1.2 3.85083 1.86718 (kg/m3)

In other words the bug can be circumvented by setting this variable to 1. I will file a bugzilla.

test-volume-drift.tar (190 KB) test-volume-drift.tar Files to reproduce the problem David van der Spoel, 09/29/2010 09:59 PM

History

#1 Updated by David van der Spoel almost 9 years ago

Created an attachment (id=544)
Files to reproduce the problem

Run with gromacs 4.0.7
grompp -v
mdrun -v
echo Dens | g_energy -w

Then run the same with gromacs 4.5.1 and see the difference.

#2 Updated by David van der Spoel almost 9 years ago

I guess the nstlist = -1 does not play nice with nstcalcenergy = 10 (default)

#3 Updated by Berk Hess almost 9 years ago

This was not due to nstcalcenergy being -1, but rather due to nstlist being -1.

Fixed it:
commit de946652ba14e3bb9953f2154f7b1653e09448a2

Berk

Also available in: Atom PDF